View Issue Details

IDProjectCategoryView StatusLast Update
0001775Multi Theft Auto : San AndreasGeneralpublic2007-03-05 14:25
Reportererorr404Assigned Tokevuwk 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001775: Include resources are loaded BEFORE map elements
Description

Functions for getting elements (getElementsByType, etc) do not recognize any map elements during onResourceStart if they are in a script that's in an include resource. If the script is in the main resource (that contains the .map file), they are recognized.

Include resource seem to load before the main resource, which could explain why they don't see the .map file's elements.

I made a resource called 'resourcestart_test' that counts the number of elements onResourceStart. The script in the main resource outputs the number of elements in the .map file correctly, the script in the include resource doesn't.

TagsNo tags attached.

Activities

kevuwk

2007-03-05 07:41

administrator   ~~0004124

i think this is same as the client side, i made it say the name of the resource when it was started and it did the main resource last which also ment it only did that one and also unloaded it last ( which i suppose is right )

kevuwk

2007-03-05 14:25

administrator   ~~0004132

it will now load the main resource first then each dependant in order and then their dependants.... this will be the same for server and client

Issue History

Date Modified Username Field Change