View Issue Details

IDProjectCategoryView StatusLast Update
0001730Multi Theft Auto : San AndreasScriptingpublic2007-06-24 07:50
Reportererorr404Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0001730: Element attachment functions should support relative positioning
Description

When you attach one element to another and use an offset, the offset will be based on the world's x, y, and z axes. Instead it should use the element's rotation and offset from that.

For example, this would allow you to attach a player to truck's bed, and have them still be on the bed even if the truck turns.

TagsNo tags attached.

Relationships

duplicate of 0001773 resolvedJax setObjectRotation & moveObject cannot work in unison 
related to 0001986 resolved X/Y offsets aren't working in element attachment 

Activities

Ransom

2006-12-23 21:27

administrator   ~~0003829

quaternions ftw

erorr404

2007-01-20 18:59

developer   ~~0003950

Hmm, duplicate? I hope this will be hard-coded and not scripted.

jbeta

2007-04-30 08:00

updater   ~~0004440

Relative positioning still ignores roll angle (rotation around the Y axis).

Jax

2007-04-30 09:12

administrator   ~~0004442

Yeah i could only add X and Z angles using trig, we need quaternions for all 3, very complicated math.

jbeta

2007-06-24 07:50

updater   ~~0004881

Fixed now, right? :9

Issue History

Date Modified Username Field Change