View Issue Details

IDProjectCategoryView StatusLast Update
0001327Multi Theft Auto : San AndreasGeneralpublic2012-01-24 19:44
ReporterRansomAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.3Fixed in Version1.3 
Summary0001327: Laffy Taffy/Roadkill CJ Model
Description

Basically CJ looks like hes been run over. I saw someone get a video of this and they said it was rare but... I've had it happen to me several times in the past betas. You basically run around as a piece of road kill... pretty impossible to play. I just got it joining error's map on gamma (noone else in). Can't really reproduce. Reproduced when someone changes clothes, and then another player suicides.

TagsNo tags attached.

Relationships

related to 0005839 resolvedccw Multi Theft Auto : San Andreas cj fat/muscle stats not resetting 
has duplicate 0005628 closed New issues Spiderbug is back 
related to 0001454 resolvedIJs Multi Theft Auto : San Andreas Deformed arms on remote players 

Activities

ChrML

2006-05-01 11:02

administrator   ~~0003013

Last edited: 2006-05-01 11:03

Happens if you leave the game up for a while when you left with a skin on I think. I'll get a screen next time it happens.
It's also worth noting that this happens to a specific skin, say this can permantently ruin skin 150 till next GTA restart. You can play normally with any other skin, but trying 150 again will cause this weird-looking CJ if it has happened once with skin 150. It can happen to more than one skin.

ChrML

2006-05-01 15:22

administrator   ~~0003014

http://thegamersalliance.com/Th!s_is_N0T_hidden_dir/heh.JPG

slothman

2006-05-05 02:03

updater   ~~0003019

I also experienced this in chrmls 03 server.

I was playing as model 33 (my favorite) and i was killed by explosion. after respawning i tried to turn back into 33, but when i did, this is what i looked like.

http://www.thegamersalliance.com/Th!s_is_N0T_hidden_dir/mutants.JPG

i could switch to other models and i looked fine, but 33 was always warped even on other players. even after another death this continued.

ChrML

2006-05-05 10:59

administrator   ~~0003021

Would be interesting seeing if this can happen to remote players too. Can anyone get someone remote to go in and change to the same skin ID that has mutated for the local player? See if the remote player gets mutated too.

slothman

2006-05-07 15:48

updater   ~~0003039

have a closer look at my pic. erorr is also warped when he changed to the same skin as me.

Gamefreek

2006-05-12 10:10

viewer   ~~0003047

I just experienced this and when i changed my skin it went away. Only thing is right when i respawned my character was completetly grey..like someone took a brush and painted him all one color

ChrML

2006-06-04 11:51

administrator   ~~0003113

Possibly fixed this

erorr404

2006-06-08 17:08

developer   ~~0003152

Still there, seems to happen a lot when I join Brophy's map 'bro'.

Ransom

2006-06-09 03:19

administrator   ~~0003153

I've gotten it once or twice testing my store.map/globalstore.lua

Talidan

2006-07-01 16:54

administrator   ~~0003278

quote from what i said in textureless topic:

"This is closely related to the roadkill bug and i think it's because of the removal of setPlayerSkin - so fr now recreates the model. I think that this excess creation of models causes it to go past one of SA's limits which messes it up.

This textureless bug can sometimes be resolved by changing skin, though this is unreliable as you may get the roadkill bug"

yeah so basically think its because of excess changing of skins or excess use of different skins. maps like brophy's use lots of different skins.

Talidan

2006-07-13 05:40

administrator   ~~0003328

Bump.

MAD_BOY found something. Setting physical stats like Fat (setstat 21 999) will cause the player to become roadkill. Respawning will make him go textureless.

BrophY

2006-07-18 14:24

updater   ~~0003336

Ye talidan, its like boobs on the female models, they only work correctly when fat and muscle are both set to 0

erorr404

2006-07-18 19:59

developer   ~~0003337

I guess this can be handled by scripts - whenever you change a players skin, change fat and muscle to 0.

jhxp

2006-09-18 05:44

administrator   ~~0003492

Solution: always set fat and muscles to 0, when changing the player skin.

Issue closed, added to the FAQ.

IJs

2007-02-24 10:10

administrator   ~~0004066

Related to skeletal modifications on models. Visual (skeletal) stats only apply to the CJ skins.

jbeta

2007-04-01 17:06

updater   ~~0004285

I don't think leaving it up to the scripter is the best solution.
Not that this is urgent, but can't visual stats be automatically set to default when changing to a ped skin?

slothman

2007-05-26 17:37

updater   ~~0004637

this problem is back in a big way, since big smoke became a usable model. same as the other related issue of textureless peds.

Xanarki

2007-06-05 22:51

reporter   ~~0004727

Last edited: 2007-06-05 22:53

This bug occurred when error404 changed clothes and then I suicided. Happens every time.

Jax

2007-06-08 13:43

administrator   ~~0004761

If this pops up again i'll go insane!

lil_Toady

2007-11-26 04:37

administrator   ~~0006455

There again.
Here's a way to reproduce:

function laffytaffy ( player, command )
spawnPlayer ( player, 1, 1, 9, 0, 24 )
spawnPlayer ( player, 1, 1, 7, 0, 0 )
setPlayerStat ( player, 23, 1000 )
setPlayerSkin ( player, 24 )
spawnPlayer ( player, 1, 1, 7, 0, 24 )
end

addCommandHandler ( "laffytaffy", laffytaffy )

BinSlayer

2010-08-19 00:04

viewer   ~~0011980

Still happens quite often (in Mr.Green Race server). We are running the latest 1.0.4 nightly build. It only happens with CJ (no custom textures). And it happens randomly, no really way of reproducing that I've found.

x86

2010-12-21 15:58

administrator   ~~0012330

Someone told me it's reproduce able by making yourself "fat" in freeroam.

JasperNL

2010-12-30 15:39

viewer   ~~0012397

How it prevents at me.

  1. Change clothes
  2. reconnect
  3. After spawn with CJ skin you look pretty fubar.

Ransom

2011-01-28 19:33

administrator   ~~0012809

Last edited: 2011-02-05 07:12

Last few notes are probably laffy taffy being caused by #5839

Relationship added.

arranTuna

2011-01-28 20:16

manager   ~~0012810

Yeah I just added a script which uses a CJ and sets his muscle now everyone is getting their skins as CJ road kill, I'll be removing it.

Willy

2011-09-06 18:12

updater   ~~0014735

getting this with setting fat stat as well as (separately) setting CJ to use gimp suit (addPedClothes - "gimpleg" "gimpleg" 17)

bug_Spanish4Life

2011-09-09 18:30

viewer   ~~0014756

Confirmed

BinSlayer

2012-01-09 23:49

viewer   ~~0015685

The issue is still present in the current MTA version.
However, if you make sure your server doesn't touch the functions (at all) addPedClothes() and setPedStat() with fat/muscle, you will not get this issue.

For race servers, the problem is because of addPedClothes(), while the race gamemode attempts to give CJ a helmet and some other features to look like a cool racer

PS: As I am not sure about fat/muscle thingy, I'm sure that addPedClothes is a problem. Maybe it's simply not resetting the data when the CJ skin is changed to something else so perhaps the devs could double check that function for possible faulties

ccw

2012-01-10 00:40

administrator   ~~0015688

Please test possible fix: http://nightly.mtasa.com/?mtasa-1.2-rc-latest

arranTuna

2012-01-10 01:00

manager   ~~0015689

I was able to reproduce it using the fix, but only one time.

TreN

2012-01-10 12:00

viewer   ~~0015693

Confirmed with latest 1.2 nightly and as arranTuna said only one time.

ccw

2012-01-10 21:40

administrator   ~~0015706

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=3678

Issue History

Date Modified Username Field Change