View Issue Details

IDProjectCategoryView StatusLast Update
0009883Multi Theft Auto : San AndreasScriptingpublic2018-09-04 22:44
ReporterPirulaxAssigned ToBonus1702 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.5 
Target Version1.5.6Fixed in Version1.5.6 
Summary0009883: :setWindowOpen() and :getMaxPassengers() methods doesnt work.
Description

I originally i wanted to open a PR to fixe these bugs, but i dont want to open a PR for 2 lines of code.

TagsNo tags attached.

Activities

pkpawelo

2018-06-21 20:53

reporter   ~~0026564

but i dont want to open a PR for 2 lines of code.

Why? This is exactly what PRs are for. There is no minimum or maximum limit of changes. You can even submit a fix for single typo and that's totally fine and appreciated :)

Pirulax

2018-06-22 22:59

reporter   ~~0026566

Gonna create a PR for fixing some missing OOP issues then :D

Bonus1702

2018-06-23 11:50

reporter   ~~0026569

Created a PR for getMaxPassengers:
https://github.com/multitheftauto/mtasa-blue/pull/200

setWindowOpen is not in MTA wiki, so it would be a feature request, not a bug.

Pirulax

2018-06-23 17:21

reporter   ~~0026571

I think you just broke backward compatibility.
Gonna fix that, and fix some other OOP methods.

qaisjp

2018-06-23 17:36

administrator   ~~0026572

The vehicle:getMaxPassengers fix is fine.

qaisjp

2018-06-23 17:39

administrator   ~~0026573

A pull request to add isVehicleWindowOpen and setVehicleWindowOpenOOP-counterparts would be appreciated, @Pirulax! Thanks.

Pirulax

2018-07-02 19:42

reporter   ~~0026595

Hi,
Alright, I'll hopefully open a PR tomorrow for them.
I've seen that they have been added as class_function, but they dont work for some reason.

Issue History

Date Modified Username Field Change