View Issue Details

IDProjectCategoryView StatusLast Update
0009774New issuesClientpublic2017-12-04 19:04
Reporterharon4iggAssigned Toccw 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows OS VersionXP/7/8/10
Summary0009774: Windows crash (BSOD) when connecting to servers
Description

For the last 4-5 days, a lot of people reporting windows crash (blue screen of death) when trying to connect to servers. No crash dumps from MTA or Windows is being produced.
I was able to reproduce the issue by many attempts to connect to some server, using a lot of graphics memory.

After system is recovered - the MTA settings (binds, favorite servers, history, passwords) being reset to defaults.

Steps To Reproduce
  1. Connect to mtasa://31.28.168.207:22016
  2. Wait until server menu is loaded.
  3. Disconnect
  4. Go to step 1. (5-8 times)
TagsNo tags attached.

Activities

ccw

2017-12-02 12:09

administrator   ~~0026312

Last edited: 2017-12-02 12:12

View 2 revisions

1) Enable 'Small Memory dump' by following these instructions:
http://mywindowshub.com/how-to-configure-windows-10-to-create-dump-files-on-bsod/
Important: Change 'Automatic Memory Dump' to 'Small Memory dump' in the final step

2) Start MTA and cause a BSOD

3) Find latest file in C:\Windows\Minidump\ and upload to https://upload.mtasa.com/ and give link here.

haron4igg

2017-12-02 12:10

viewer   ~~0026313

Some player reports the message from BSOD windows:
PAGE_FAULT_IN_NONPAGED_AREA.
FairplayKD.sys

ccw

2017-12-02 12:16

administrator   ~~0026314

Does he have any files in C:\Windows\Minidump\ ?

haron4igg

2017-12-02 12:27

viewer   ~~0026315

https://upload.mtasa.com/u/438453094/120217-18969-01.dmp_

ccw

2017-12-02 16:09

administrator   ~~0026316

Unfortunately that dump comes from an 'unofficial' Windows installation, so there are no debug symbols available.
Need a dump from another PC.

haron4igg

2017-12-02 16:31

viewer   ~~0026317

Bad to hear, my people doesr have official windows, only cracked repacks.... and my windows installed on bootcamp, probably because of it i dont see bsods, no reports and dumps. Pc jusr freeze. How can i understand that dump is valid? I will keep looking...

ccw

2017-12-02 19:59

administrator   ~~0026319

Last edited: 2017-12-02 20:04

View 2 revisions

Check if a dump file is valid by downloading https://nightly.mtasa.com/files/temp/dump_check.bat and dragging the .dmp file onto dump_check.bat

haron4igg

2017-12-02 20:59

viewer   ~~0026322

yey! found one: https://upload.mtasa.com/u/739574541/120217-27062-01.dmp_

Sasuke*

2017-12-03 00:41

viewer   ~~0026323

Here is mine https://upload.mtasa.com/u/729634314/120217-30921-01.dmp_

ccw

2017-12-03 01:00

administrator   ~~0026324

Try this build of MTA:

https://nightly.mtasa.com/mtasa-1.5.5-full_rc-11734-20171019.exe

haron4igg

2017-12-03 14:10

viewer   ~~0026327

The BSOD problem seems to be solved. at least for me.
During first reproducing cycle, got this crash on second attempt (usually such kind of crash appears after 4-8 attempt, depends on RAM size)
And then one more crash appeared, on 6th attempt (as usual, before BSOD problem)

ccw

2017-12-03 16:54

administrator   ~~0026328

Please try this now:
https://nightly.mtasa.com/mtasa-1.5.5-full_rc-11785-20171203.exe

haron4igg

2017-12-03 18:42

viewer   ~~0026330

Much better! Crashed after 10th attempt :D

Issue History

Date Modified Username Field Change