View Issue Details

IDProjectCategoryView StatusLast Update
0009676New issuesScriptingpublic2017-07-18 19:33
Reportereinheit-101Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0009676: setWeaponProperty() on any skill level for "Rifle" (33) applies the property to all skill levels
Description

It seems like the Rifle has only 1 skill level.
Setting a weapon property of the rifle for "poor" skill will also change that value for "pro" and "std" skill levels.

Steps To Reproduce

-Get a rifle
-set your sniper skill level to "pro"

srun setWeaponProperty("rifle", "poor", "accuracy", 0.01)

-> You are on skill level pro and just set the accuracy of the rifle to a very low value for "poor", but the accuracy of the rifle on "pro" is now low aswell.

Additional Information

Another issue is the fact that some weapons (aka Minigun) have no skill levels at all, and because of these issues its currently not possible to create 3 different variants of Rifle/Minigun.

TagsNo tags attached.

Activities

arranTuna

2017-07-18 19:33

manager   ~~0026069

This isn't a bug. This weapon doesn't have skill levels set in GTA SA. Many weapons such as sniper rifle, minigun, etc behave the exact same way, it's not a bug it's a lack of feature.

Issue History

Date Modified Username Field Change