View Issue Details

IDProjectCategoryView StatusLast Update
0009631Multi Theft Auto : San AndreasClientpublic2018-07-16 20:15
ReportervireloxAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product Version1.5.4 
Target VersionFixed in Version1.5.5 
Summary0009631: playSound (UTF 8)
Description

playSound does not support utf8 characters

Steps To Reproduce

crun playSound("http://translate.google.com/translate_tts?tl=pl&q=Proszę o poprawę błędu&client=tw-ob")

Additional Information

playSound does not support utf8 characters

TagsNo tags attached.

Activities

virelox

2017-05-11 22:48

viewer   ~~0025929

Last edited: 2017-05-11 22:49

View 2 revisions

Steps To Reproduce (Edit): https://pastebin.com/qsixFJ5C

Necktrox

2017-05-11 23:12

developer   ~~0025931

You have to URL encode your query parameters. You can find a code snippet here: http://lua-users.org/wiki/StringRecipes

virelox

2017-05-12 12:46

viewer   ~~0025933

Not work :(
Code: https://pastebin.com/JwPxPgZq

Necktrox

2017-05-12 18:00

developer   ~~0025934

translate.google.com only throws a HTTP ERROR 403.

Try to use this: https://wiki.multitheftauto.com/wiki/ConvertTextToSpeech

virelox

2017-05-12 18:39

viewer   ~~0025935

This function only trigger, nothing else.
But anyway I checked it and does not work, function does not return sound.
Code: https://pastebin.com/VaAGtUwZ

Necktrox

2017-05-12 20:00

developer   ~~0025939

Last edited: 2017-05-12 20:01

View 2 revisions

Can I close this issue, because playSound is working fine and you do only have problems with finding a working & free Text-to-Speech service?

virelox

2017-05-12 20:47

viewer   ~~0025940

1.5.4 changelog says that playSound supports unicode in URLs now. URL and TTS services that i've used are working fine on normal browser. playSound supports this TTS, but without polish characters.

Issue History

Date Modified Username Field Change