View Issue Details

IDProjectCategoryView StatusLast Update
0009542New issuesScriptingpublic2017-02-11 12:10
ReporterDrakathAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Summary0009542: [Request] Add "Server shutdown" quit reason to onPlayerQuit
Description

I have a save script that saves the game progress on two occasions: onPlayerQuit and onResourceStop (in case of restarting the resource). When the server shuts down or restarts, the save script is triggered two times. It would be great to have a quitType "Server shutdown" to prevent onPlayerQuit part from executing.

TagsNo tags attached.

Activities

arranTuna

2017-01-29 19:56

manager   ~~0025656

What is the quit type / reason when the server is shutting down currently? Also I don't see the issue because by the time onResourceStop is called there would be no players left so it wouldn't even be saving the data twice.

Jusonex

2017-01-30 21:31

administrator   ~~0025659

If you're looking for a more generic solution, using onElementDestroy instead of onPlayerQuit might fix your problem.

Drakath

2017-02-08 20:58

viewer   ~~0025668

Alright, this is not necessary after all. Close please.

Issue History

Date Modified Username Field Change