View Issue Details

IDProjectCategoryView StatusLast Update
0009530Multi Theft Auto : San AndreasServerpublic2017-11-11 23:05
ReporterDrakathAssigned Toccw 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.6 
Summary0009530: Server crashed when using the 'upgrade' command
Description

I was upgrading a resource with a missing min_mta_version in its meta.xml and the server crashed.
Server version: MTA:SA Server v1.5.3-release-11062
I couldn't reproduce it on release-10820 and haven't tried it on my main server.
Crash dumps: http://upload.mtasa.com/u/419029568/upgrade_crash.zip_

Additional Information

Log:
[2017-01-15 15:46:26] WARNING: stats <min_mta_version> section in the meta.xml is incorrect or missing (expected at least client 1.5.2-9.07903 because of 'c_stats.luac')
[2017-01-15 15:46:26] WARNING: stats requires upgrade as <min_mta_version> section in the meta.xml is incorrect or missing (expected at least client 1.5.2-9.07903 because of 'c_stats.luac')
[2017-01-15 15:46:26] Use the 'upgrade' command to perform a basic upgrade of resources.
[2017-01-15 15:46:26] Starting stats
[2017-01-15 15:46:26] start: Resource 'stats' started
[2017-01-15 15:46:36] Upgrading stats:meta.xml ...........done
[2017-01-15 15:46:36] Resource 'stats' changed while running, reloading and restarting
[2017-01-15 15:46:36] Stopping stats
[2017-01-15 15:46:36] New resource 'stats' loaded

TagsNo tags attached.

Activities

Drakath

2017-11-11 18:34

viewer   ~~0026282

Another crash happened today: https://upload.mtasa.com/u/171965210/crash_dump.zip_
This time it was on MTA:SA Server v1.5.4-release-11428

ccw

2017-11-11 21:31

administrator   ~~0026283

Any server log output after the upgrade command?

Drakath

2017-11-11 21:45

viewer   ~~0026284

These were the last outputs before the crash:

[2017-11-11 14:13:00] restart: Requested by Console
[2017-11-11 14:13:00] restart: Resource restarting...
[2017-11-11 14:13:00] Stopping Shops
[2017-11-11 14:13:00] Resource 'Shops' changed, reloading and starting
[2017-11-11 14:13:00] WARNING: Shops <min_mta_version> section in the meta.xml is incorrect or missing (expected at least server 1.5.2-9.07903 because of 'server/server.luac')
[2017-11-11 14:13:00] WARNING: Shops requires upgrade as <min_mta_version> section in the meta.xml is incorrect or missing (expected at least server 1.5.2-9.07903 because of 'server/server.luac')
[2017-11-11 14:13:00] Use the 'upgrade' command to perform a basic upgrade of resources.
[2017-11-11 14:13:00] Starting Shops
[2017-11-11 14:13:01] Shops restarted successfully
[2017-11-11 14:13:04] Upgrading Shops:meta.xml ...........done
[2017-11-11 14:13:04] Resource 'Shops' changed while running, reloading and restarting
[2017-11-11 14:13:04] Stopping Shops
[2017-11-11 14:13:04] New resource 'Shops' loaded
[2017-11-11 14:13:04] Resource 'admin' changed while running, reloading and restarting
[2017-11-11 14:13:04] Stopping admin
[2017-11-11 14:13:04] New resource 'admin' loaded

I don't know why did the admin resource restart itself since I didn't change anything except an in-game setting. The command I typed in was: "upgrade Shops"

ccw

2017-11-11 23:05

administrator   ~~0026285

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/ecdf63af649854568199771d4c169c20753a53c0

Issue History

Date Modified Username Field Change