View Issue Details

IDProjectCategoryView StatusLast Update
0009497Multi Theft Auto : San AndreasClientpublic2016-12-17 18:53
ReporterBloodStar18Assigned Toccw 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.3 
Target Version1.5.4Fixed in Version1.5.4 
Summary0009497: Ped weapon dissappears after stream out
Description

If we give ped weapon when ped is streamed in and then go away from him, weapon dissappears from his hands. We can check ped weapon with 'getPedWeapon'. It will returns that weapon is in his hands now. But no visual effect and proper animations.

Steps To Reproduce

Create ped, give him a weapon before join server. Or give ped weapon when he streamed in and leave him. After it get back to him and you will not see weapon in ped hands.

TagsNo tags attached.

Activities

arranTuna

2016-12-16 11:51

manager   ~~0025498

Around the time I made givePedWeapon I don't think this was bugged, I even made code that fixed this bug you can see in the patch file: https://bugs.mtasa.com/view.php?id=8638 Note the cases of: "// Store the ammo so it's not lost if a ped is streamed out" so someone must have changed something since then to do with ped weapons. If github has something like SVN blame, should be able to find the commit that broke this.

ccw

2016-12-16 13:16

administrator   ~~0025499

Looks like current weapon is not being set on stream in.

ccw

2016-12-16 15:26

administrator   ~~0025501

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/a69ad1cd593db2ed8a3191b60c9769774b47b988

Test in https://nightly.mtasa.com/mtasa-1.5.3-full_rc-10963-20161216.exe

BloodStar18

2016-12-17 04:37

viewer   ~~0025504

Thank you!

arranTuna

2016-12-17 18:40

manager   ~~0025505

Confirmed as fixed.

Issue History

Date Modified Username Field Change