View Issue Details

IDProjectCategoryView StatusLast Update
0009476Multi Theft Auto : San AndreasGUIpublic2016-12-19 22:00
ReporterWalid_Assigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.3 
Target Version1.6Fixed in Version1.5.4 
Summary0009476: guiCreateMemo can't type some languages into memo boxes
Description

I can't write arabic in memo

Steps To Reproduce

guiCreateMemo() > and just try to write something in arabic

Additional Information
  • You can set arabic text using guiSetText().
  • You can copy/paste arabic into a memo.
  • With guiCreateEdit working fine.
TagsNo tags attached.

Activities

arranTuna

2016-11-30 11:41

manager   ~~0025448

My translation system uses memos and it has been used to translate English to Arabic so this can't be a problem for everyone.

Walid_

2016-11-30 21:35

viewer   ~~0025451

Me too i have translation system i create it 3 years ago it have more than 13 languages, but what i'm talking about is you can't write arabic with your keyboard in memos, you can copy/paste , also you can use guiSetText.
Before i report this i tried to write something in arabic in your CITphone memo but i can't, same problem in other servers.

arranTuna

2016-12-06 15:21

manager   ~~0025473

Turns out that they hadn't reported this problem to me, until now, this video shows that they can't type Chinese into a memo box yet they can type it into the console edit box: https://youtu.be/gZev2Bhp3jI?t=69

ccw

2016-12-19 22:00

administrator   ~~0025510

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/b075a56b894a06a9498923ea8283413a6423386d

Please test with https://nightly.mtasa.com/?mtasa-1.5-latest

Issue History

Date Modified Username Field Change