View Issue Details

IDProjectCategoryView StatusLast Update
0009449Multi Theft Auto : San AndreasClientpublic2016-10-31 14:22
ReporterStifflersMomAssigned ToJusonex 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.3 
Target Version1.5.4Fixed in Version1.5.4 
Summary0009449: engineReplaceModel in 1.5.3-release-10721 crashes the client
Description

Version = 1.5.3-release-10721.0.000
Time = Sun Oct 30 21:05:22 2016
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x00349B93

EAX=1EE184DC EBX=0028F048 ECX=00000000 EDX=5A479068 ESI=1EE18490
EDI=1D6EE648 EBP=0028F08F ESP=0028F00C EIP=0028F08F FLG=00010203
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

also followed by a warning

MTA: San Andreas [CL34] (CTRL+C to copy)

GTA:SA had trouble loading a model. (525)

If you recently modified gta3.img, then try reinstalling GTA:SA.

Do you want to see some on-line help about this problem ?

Yes No

Steps To Reproduce

Any engineReplaceModel does "the job" ...

TagsNo tags attached.

Activities

Dutchman101

2016-10-30 23:31

updater   ~~0025363

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/07f95ef0173a446de36ca2e60085bde0b3505de2

Dutchman101

2016-10-30 23:54

updater   ~~0025365

Last edited: 2016-10-30 23:56

View 2 revisions

The crashfix doesn't solve it. Still occurs after nightly including it was built. (likely because the fix was made by Jusonex without knownledge of this bugreport/steady repro with engineReplaceModel and based off dumps - while the same issue..)

Re-opened

Dutchman101

2016-10-31 07:20

updater   ~~0025366

Re-fixed in https://github.com/multitheftauto/mtasa-blue/commit/17ee33205bc2a09a724a7f5d168bff2fdd776f70
mark resolved

StifflersMom

2016-10-31 09:51

updater   ~~0025367

It's fixed with 10724, can be closed :)

Issue History

Date Modified Username Field Change