View Issue Details

IDProjectCategoryView StatusLast Update
0009386Multi Theft Auto : San AndreasScriptingpublic2017-06-29 00:52
Reportereinheit-101Assigned Tolopezloo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.3 
Target Version1.5.4Fixed in Version1.5.4 
Summary0009386: engineSetModelLODDistance() does not change the LOD distance of vehicle models
Description

As in the description said, vehicles will display their low LOD model always after ~90m distance. Using engineSetModelLODDistance(498, 300) does nothing, however, in my opinion, this should enable rendering the high LOD model up to 300m instead of just 90.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 10

2017-01-25 12:29: einheit-101 (EUR 10)
Users sponsoring this issue (Total Sponsorship = EUR 10)

Activities

lopezloo

2016-09-23 21:44

developer   ~~0025230

I'm currently working on something like this:
bool setVehiclesLODDistance ( float vehiclesDistance, float boatDistance = vehiclesDistance, float trainsAndPlanesDistance = vehiclesDistance * 2.14 )

Plus scrollbar in options: http://i.imgur.com/Vlxkmd8.png

The question is: should I keep scrollbar with values between 30 - 250 or maybe just create tick "Render vehicles always in high quality"?

einheit-101

2016-09-23 22:40

reporter   ~~0025231

On my server I need all vehicles in full quality because of long-range (300m) tank engagements. The lowLOD doesn't show the tank turret. Personally on my system I would enable Max quality. Maybe the best option would be to keep the scrollbar but the highest value should be "always HQ".
A scripting function to force the HQ model would be nice Aswell, I could delete all LODs from my 24 vehicles and save some Memory.

ccw

2016-09-23 23:18

administrator   ~~0025235

A check box is preferable.
How does the script function interact with the option setting?

lopezloo

2017-02-21 15:13

developer   ~~0025678

Thanks for bump. Meanwhile I changed scrollbar to checkbox and I dropped support for boats (for simplicity, I'm patching only 2 addresses now), they use general vehicles distance now. I set limit to 500 which is a bit more than streaming distance.

^
setVehiclesLODDistance() will override user setting and resetVehiclesLODDistance() will reset value according to checkbox.

PR: https://github.com/multitheftauto/mtasa-blue/pull/113

einheit-101

2017-02-22 22:37

reporter   ~~0025679

God, thx i will try this so hard asap.
Where should the 10€ go then?

https://mtasa.com/donate/manage.php

??

ccw

2017-02-23 00:12

administrator   ~~0025680

Send it to the fixer

einheit-101

2017-02-25 00:37

reporter   ~~0025683

Already implemented and will now be tested for the future. Works great and just as planned so far.

lopezloo

2017-04-28 01:38

developer   ~~0025849

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/efb8e388ef2e5ea6f5d50437ad40403adcc71828.
Bounty payed.

Issue History

Date Modified Username Field Change