View Issue Details

IDProjectCategoryView StatusLast Update
0009336Multi Theft Auto : San AndreasClientpublic2018-02-21 00:25
ReporterDrakathAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.5.2 
Target VersionFixed in Version1.5.3 
Summary0009336: MTA sometimes fails at loading custom textures
Description

I have a few skin textures that often don't load when using engineImportTXD() and engineLoadTXD(). There is no error or warning outputted when the loading fails. The problem does not occur with other textures.
It would be very helpful if there was a way to check whether the skin has loaded or not.

Steps To Reproduce

http://upload.mtasa.com/u/274366404/textureTest.zip_
Start this resource. If every skin loads then restart MTA and try it again. After several tries, the skin textures will not load.

TagsNo tags attached.

Activities

AlexTMjugador

2016-08-25 16:49

viewer   ~~0025093

This was fixed in 1.6 r9893: https://buildinfo.mtasa.com/?Revision=9893

ccw

2016-08-25 18:17

administrator   ~~0025097

Please test

einheit-101

2016-08-25 23:41

reporter   ~~0025100

I noticed sometimes dffs dont load aswell (i replace ~15 objects and sometimes one of them is still default after resourceStart, reconnect fixes it), but i never had any issue with textures.

qaisjp

2016-08-26 04:03

administrator   ~~0025101

The issue appears to be fixed now.

Drakath

2016-08-26 10:04

viewer   ~~0025104

It works for me too with latest build. Thanks for fixing this.

Issue History

Date Modified Username Field Change