View Issue Details

IDProjectCategoryView StatusLast Update
0009316Multi Theft Auto : San AndreasCEFpublic2016-09-11 16:54
ReporterthisdpAssigned ToJusonex 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindows 10 ProOS VersionWindows 10 Pro
Product Version 
Target Version1.5.3Fixed in Version1.5.3 
Summary0009316: CEF title crashed MTA
Description

Recently I am learning javascript on MTA CEF. I did something wrong when setting browser's title. I found this one can crash my MTA:

document.title = "getting\"

It was found by a mistake.

TagsNo tags attached.

Activities

thisdp

2016-08-01 08:53

viewer   ~~0025006

Last edited: 2016-08-01 08:54

View 2 revisions

The code is Javascript.
And I think is char "\" crashed it

thisdp

2016-08-01 09:08

viewer   ~~0025007

Ok I found what real crash my MTA.

local bro = guiCreateBrowser(100,100,200,200,false,false,false)
local browser = guiGetBrowser(bro)
loadBrowserUrl(browser,"http://www.youtube.com")

when browser wasn't initialized completely, load url can crash MTA.

Jusonex

2016-09-03 23:55

administrator   ~~0025132

Can't reproduce this. Could you please provide a test resource?

thisdp

2016-09-04 08:14

viewer   ~~0025134

the reason of crash isn't CEF title. The mainly problem is to operate on browser as soon as the browser created

Jusonex

2016-09-04 10:03

administrator   ~~0025136

Could you please zip all files from C:\Program Files (x86)\MTA San Andreas 1.5\MTA\dumps\private and upload the archive here or on https://upload.mtasa.com?

thisdp

2016-09-09 14:30

viewer   ~~0025155

http://upload.mtasa.com/u/779154278/client_1.5.2-release-9928.0.000_libcef_0018e6c9_3_DMb_0100007F_55F3_054_7C645_20160909_2029.dmp_

thisdp

2016-09-09 15:41

viewer   ~~0025156

local browser = guiGetBrowser(bro)
loadBrowserUrl(browser,"http://www.youtube.com")
getBrowserSource(browser,function() end)

Jusonex

2016-09-11 16:53

administrator   ~~0025170

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/7823ea12d12a8ff5ea91b09c7419b24911f61525

Issue History

Date Modified Username Field Change