View Issue Details

IDProjectCategoryView StatusLast Update
0009310Multi Theft Auto : San AndreasServerpublic2018-02-21 00:21
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.3 
Summary0009310: A connecting player can block a resource from starting
Description

I've had this problem before where you restart a resource and it stops but doesn't start again and it says there was a player that was connected below the minimum version. But there are 2 problems with this:

  1. The server has a valid minimum client version: <minclientversion>1.5.2-9.08077.0</minclientversion>
  2. The player didn't actually join the server.

I have a resource which starts all other resources (because it's much easier to update a resource that mtaserver.conf) and this resource will cancel onPlayerConnect until all resources have started but there's a big problem, I even tried to add a password to see if that stops the players blocking the resources starting:

[2016-07-26 12:06:07] CONNECT: Blah failed to connect (Wrong password) (IP: 1.2.3.4 Serial: BLAHBLAHBLAH Version: 1.5.2-9.08077.3)
[2016-07-26 12:06:07] Not starting resource BlahBlah as 1 connected player(s) below required client version 1.5.2-9.07903

TagsNo tags attached.

Issue History

Date Modified Username Field Change