View Issue Details

IDProjectCategoryView StatusLast Update
0009269Multi Theft Auto : San AndreasServerpublic2016-06-15 20:00
Reportereinheit-101Assigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.5.2 
Target Version1.5.3Fixed in Version1.5.3 
Summary0009269: Some players get "join flood" error for no reason while others don't
Description

As summary says. I am able to connect without problems. Many other people can. But there are many other people who cannot join my server because they get the CD36 error message.
Restarting the server did not solve the issue. I have no clue what's going on.

Steps To Reproduce

Join my server, maybe you are affected by this, maybe not

TagsNo tags attached.

Activities

ccw

2016-06-14 20:55

administrator   ~~0024795

Next time it happens, use the command 'debugjoinflood' in the server console and show the results here.

einheit-101

2016-06-14 23:26

reporter   ~~0024798

Last edited: 2016-06-14 23:28

View 2 revisions

Here is a fast example of one man who seems to be affected:
http://imgur.com/j3zHg25

[
CurrentTime: 0x571837c
TimeLastRemoveExpired: 0x5047622
HistoryItems: 1
TickCountAdd: 0x0
DebugTickCountOffset: 0x0
IP:d70d695d 7157182(0x5044dbe) 7155117(0x50455cf) 7152655
(0x5045f6d) 7150666(0x5046732) 7148752(0x5046eac)
]

ccw

2016-06-15 01:00

administrator   ~~0024801

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/994fc50cc4673ef9d672a345bebfc58aee6010a1

Workaround is not to set <recommendedclientversion> in mtaserver.conf

einheit-101

2016-06-15 18:54

reporter   ~~0024806

Last edited: 2016-06-15 18:55

View 2 revisions

Updated sever, still got that error.
debugjoinflood
[12:52:47] CurrentTime: 0xa07563
TimeLastRemoveExpired: 0x7c5e26
HistoryItems: 1
TickCountAdd: 0x0
DebugTickCountOffset: 0x0
IP:941281f 2367120(0x7c56d3) 2365245(0x7c5e26)

[MTA:SA Server v1.5.2-release-8028]

ccw

2016-06-15 19:19

administrator   ~~0024807

The bug was in the client.
Workaround is not to set <recommendedclientversion> in mtaserver.conf

einheit-101

2016-06-15 20:00

reporter   ~~0024808

Ah client side bug. Didn't know, sorry :D

Issue History

Date Modified Username Field Change