View Issue Details

IDProjectCategoryView StatusLast Update
0009264Multi Theft Auto : San AndreasCEFpublic2016-09-03 23:47
ReporterdrifterCZAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5.3Fixed in Version1.5.3 
Summary0009264: CEF should not block mouse buttons when focused
Description

focusBrowser ( ) function should only read for keyboard characters, and keep mouse untouched (do not block it), as it cannot get any input from it by this way anyway.

Currrently when we use focusBrowser, we cannot scroll the page, because onClientKey for mouse_wheel_up and mouse_wheel_down stops triggering. Other mouse buttons doesnt work aswell, but this can be overworked using "onClientClick" event. Scroll can not.

TagsNo tags attached.

Activities

drifterCZ

2016-06-12 17:55

viewer   ~~0024778

Generaly, when the browser is focused, there is NO WAY to scroll (except draging the sliders like a fool)

Jusonex

2016-09-03 23:47

administrator   ~~0025131

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/ec82be037b2f20c97b468632773f1d56d09c31e6

Issue History

Date Modified Username Field Change