View Issue Details

IDProjectCategoryView StatusLast Update
0009218Multi Theft Auto : San AndreasScriptingpublic2016-04-27 22:20
Reportereinheit-101Assigned Toccw 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.5.2 
Target Version1.5.3Fixed in Version1.5.3 
Summary0009218: low LOD streaming causes objects to disappear
Description

(Summary was: [Request] something like engineSetLODDrawDistance())

This function would be used to manipulate the LOD draw distance. Current LOD draw distance is ~1000m which causes ridiculous issues if your map has more than 200-300 objects since using LOD effectively doubles the object count. Using a LOD distance of 1000m means that only 250 objects could be drawn in a radius of 1000m around the player which is "nothing".

Reducing the LOD distance to 500m with engineSetLODDrawDistance(500) would mean that the mapper can place up to 250 objects in a radius of 500m instead of 1000 before THIS HAPPENS:

http://i1085.photobucket.com/albums/j430/bryan192/gta_sa2012-05-2718-11-36-03.jpg~original

Steps To Reproduce

Other solutions
-Higher object streaming limit, so MTA doesnt care if there are just 500 objects or 500 objects + 500 LODs

-Improve the LOD system so it doesnt create 1 LOD object for each Object, doubling the object count unnessecary

TagsNo tags attached.

Activities

ccw

2016-04-13 21:21

administrator   ~~0024610

There are improvements that could be made to the object and LOD system, and I will look at it shortly.

However, increasing the draw distance from 300 to 1000 means there is 10 times the area to cover, so will still require care and planning
even after improvements have been made.

For example, only use low LOD objects for large important areas such as landmasses and large buildings. Objects such as trees, signs etc do not need a low LOD object.

einheit-101

2016-04-14 04:14

reporter   ~~0024611

I already tried to use LOD objects only for large objects but even then most maps start being unusable. Increasing the draw distance of default objects would be no solution with the current streamer. The "easiest" method i can think of would be the ability to limit the LOD distance. So i could use LODs only for some huge objects and reduce their LOD Distance to 500 or 400 and it wont break my maps like 1000 does.

ccw

2016-04-14 06:41

administrator   ~~0024612

Please try with 1.6 r7951
https://nightly.mtasa.com/

einheit-101

2016-04-14 12:35

reporter   ~~0024613

Last edited: 2016-04-14 12:36

View 2 revisions

I have the exact same outcome, what exactly has been changed? Due to the high draw distance of LOD Objects i still can see them always and they seem to force non-LOD elements to stream out.
Long story short: I fall through the ground because MTA is only using LOD objects. I can make a video of it.

Maybe MTA should stream lowLOD objects only if there are free streaming nodes, otherwise no LODs should be streamed. And only the closest LODs should be streamed if the nodes are on their limit (but i think MTA does already do this)

ccw

2016-04-14 18:50

administrator   ~~0024615

Please give me a resource which shows the problem.

einheit-101

2016-04-14 19:49

reporter   ~~0024616

Last edited: 2016-04-14 20:12

View 3 revisions

https://www.dropbox.com/s/95axj0llzbabnfd/AfriLod.zip?dl=0

This map has enabled LOD and is unplayable. Only the big objects use LOD, i removed all other objects. The map has ~"100"-"150" objects that use LOD and ~"700" objects in total distributed over ~2 square miles.

Example video:
https://www.youtube.com/watch?v=8GGubHzHiso&feature=youtu.be

ccw

2016-04-15 00:00

administrator   ~~0024617

Try 1.6 r7952

einheit-101

2016-04-15 04:00

reporter   ~~0024618

This is beautiful O_O
The LOD streaming is far better now! It looks like default objects have a higher priority than LOD objects, they do not longer stream out and cause issues!
The streaming itself is a lot "smoother" now, too. It seems to be a great improvement over anything before!

https://youtu.be/E1BLOsYXdg4

ccw

2016-04-27 22:20

administrator   ~~0024653

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/87381f2c5aebf1e771c14f2c8c6912bede39c57a

Issue History

Date Modified Username Field Change