View Issue Details

IDProjectCategoryView StatusLast Update
0009179Multi Theft Auto : San AndreasServerpublic2016-03-09 23:27
ReporterKenixAssigned Toccw 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
PlatformLinuxOSCent OSOS Version7
Product Version1.5.2 
Target Version1.5.3Fixed in Version1.5.3 
Summary0009179: Server crashed after random time
Description

Server crashed after random time
Tested on MTA:SA Server v1.5.2-release-7838
I think it's a memory leak but i can catch it. I write custom performancestats (log all stats in each file after 5 seconds) but it is not helped.

After crash all players see error "NETWORK TROUBLE" and all players disconnected.

Steps To Reproduce

Run the server.
Wait crash after random time..

Additional Information

Custom Performance Stats Logs before server crashed: http://pastebin.com/n2d6xWbr

Archive:
http://s000.tinyupload.com/?file_id=77725294109998048827

Dump:
http://pastebin.com/AExherue

Archive of dumps and logs:
http://s000.tinyupload.com/index.php?file_id=68647746741971683007

TagsNo tags attached.

Activities

Kenix

2016-03-09 21:58

updater   ~~0024516

Last edited: 2016-03-09 22:02

View 2 revisions

I will try generate core dump later.

ccw

2016-03-09 22:43

administrator   ~~0024517

Do you have an event handler for 'onVehicleRespawn' ?

Kenix

2016-03-09 23:00

updater   ~~0024518

Last edited: 2016-03-09 23:03

View 3 revisions

Yes i have (method from CVehicle class)
http://pastebin.com/imgG1nKy

onVehicleRespawn attached to resourceRoot

ccw

2016-03-09 23:22

administrator   ~~0024519

The crash is caused by calling toggleVehicleRespawn during onVehicleRespawn.

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/a64feedd6a1dfd742846e2bce76897ed394c1265

Kenix

2016-03-09 23:27

updater   ~~0024521

Big thanks mate!

Issue History

Date Modified Username Field Change