View Issue Details

IDProjectCategoryView StatusLast Update
0009155Multi Theft Auto : San AndreasScriptingpublic2016-04-20 22:11
ReporterarezuAssigned Toqaisjp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindows 10OS Version
Product Version1.5.2 
Target VersionFixed in Version1.5.3 
Summary0009155: Object 6458 no longer exists
Description

I found a race map that has object with model 6458 and the name of the object is pier03Tr_LAw2, but when I cant find it in the map editor.
Im able to create an object with that model without any error or warning, but when I use engineGetModelNameFromID with the model, or engineGetModelIDFromName with the name, then both give warning about non-valid model.

Has the object been removed but createObject has not been updated?

Steps To Reproduce

createObject(6458, 0, 0, 10) -- ok
engineGetModelNameFromID(6458) -- warning
engineGetModelIDFromName("pier03Tr_LAw2") -- warning

Additional Information

Running both server and client on v1.5.2-release-7849

TagsNo tags attached.

Activities

arezu

2016-02-21 14:21

viewer   ~~0024425

Last edited: 2016-02-21 14:22

View 2 revisions

The map with that object was made in 2013, and I verified that the object actually is created and I can see it, so it looks like an issue with engineGetModelNameFromID and engineGetModelIDFromName (and map editor)

qaisjp

2016-02-21 19:59

administrator   ~~0024427

The code for model names hasn't been touched in about five years ( https://github.com/multitheftauto/mtasa-blue/commit/6a466243dfcb1863a22a655823e4f005041f1888 ) so I don't think it has been removed.

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/72a3e3a7d919ce17fde13bb30b8bc27ef1d4c9cc

See http://buildinfo.mtasa.com/?SHA=72a3e3a7d919ce17fde13bb30b8bc27ef1d4c9cc when it updates.

qaisjp

2016-04-20 22:11

administrator   ~~0024640

Added to 1.5.2 nightlies in r7973
https://buildinfo.mtasa.com/?Revision=7973

Issue History

Date Modified Username Field Change