View Issue Details

IDProjectCategoryView StatusLast Update
0009151Multi Theft Auto : San AndreasScriptingpublic2017-05-23 18:39
ReporterPiorunAssigned Toccw 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionopen 
Product Version 
Target Version1.5.5Fixed in Version1.5.5 
Summary0009151: [Request] POST,PUT,GET and UPDATE to fetchRemote
Description

Hi,

I have an idea to insert some new argument to fetchRemote which will be http method for restful api. It would help create really powerfull and safe MTA resources.

TagsNo tags attached.

Activities

Piorun

2016-03-02 23:04

viewer   ~~0024494

Also it would be ultra awesome if postData could be in format "key1=value1&key2=value2...". Ye i know i can parse string but i prefer using for ex. $_POST array to get data instead of parsing something from string.

Piorun

2017-03-28 23:47

viewer   ~~0025780

Really, no one cares about this one? I want to make server which is "speaking" with API through REST requests. I can make GET and POST easy but c'mon - where is PUT, PATCH, DELETE ...

Inspirator

2017-03-29 10:17

viewer   ~~0025782

Last edited: 2017-03-29 10:19

View 2 revisions

I think you're looking for this?

https://wiki.multitheftauto.com/wiki/Modules/cURL

Piorun

2017-03-29 12:13

viewer   ~~0025784

Yes, I found that before but ..

[IN WIKI]
Operating system: Windows

I need it on Linux.

Piorun

2017-03-29 12:22

viewer   ~~0025785

Sadly I also needs this on Windows but ..

download link is broken.

iam2noob4u

2017-03-29 16:13

viewer   ~~0025786

Last edited: 2017-03-29 16:14

View 2 revisions

I have fixed some of the links, but the link to the compiled version seems to be down. Somebody will have to (re)compile or (re)upload it.

There are some commits on GitHub which refer to fixing the linux compilation so you just might be in luck there. There are also commits which are more recent than the last release of the listed supported versions, so it might even work with newer versions of MTA.

You could always add an issue to the module's GitHub page: https://github.com/mrdejong/mta_curl/issues if you have problems with the module.

You can always use GET/POST requests instead of PUT, PATCH, DELETE requests (if you have control over the API). You can parse the string into $_POST and then use $_POST as you would normally.

Necktrox

2017-05-23 14:49

developer   ~~0025979

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/ffa943c043ddd9d4e3a49b55a13218091862e02b

Issue History

Date Modified Username Field Change