View Issue Details

IDProjectCategoryView StatusLast Update
0009021Multi Theft Auto : San AndreasScriptingpublic2018-09-05 22:31
ReporterNecktroxAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version1.5 
Target VersionFixed in Version 
Summary0009021: Bad resource userdata for onResourceStop on "removed while running"
Description

If you remove/move a resource while running and refresh your resources, the handler for onResourceStop will receive a "dead" resource userdata.

Steps To Reproduce

start xyz
srun addEventHandler("onResourceStop", root, function (res) getResourceName(res) end)
-- move xyz into other folder
refresh

Additional Information

Resources, which clean up special data after resources will have memory leaks, because the stopped resource's data won't be deleted due to the error.

TagsNo tags attached.

Activities

qaisjp

2015-08-30 16:29

administrator   ~~0024032

It's probably a good idea not to move resources without stopping them.

Necktrox

2015-08-30 16:33

developer   ~~0024033

Of course, but the resource userdata remains invalid in that event and you can't validate it.

qaisjp

2018-09-05 22:31

administrator   ~~0026979

Moved to https://github.com/multitheftauto/mtasa-blue/issues/372

Issue History

Date Modified Username Field Change