View Issue Details

IDProjectCategoryView StatusLast Update
0008995Multi Theft Auto : San AndreasScriptingpublic2016-08-24 04:17
ReporterqaisjpAssigned Toqaisjp 
PrioritynoneSeveritytrivialReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.5.2 
Target Version1.5.3Fixed in Version1.5.3 
Summary0008995: Deprecate showPlayerHudComponent
Description

I think showPlayerHudComponent should be deprecated in 1.6 (perhaps start warning servers that use the function in 1.5.1?) - it's identical to setPlayerHudComponentVisible.

What do you think about deprecating this function?

TagsNo tags attached.

Activities

AlexTMjugador

2015-08-14 17:17

viewer   ~~0023931

I think that deprecating showPlayerHudComponent would be a gooid idea. setPlayerHudComponentVisible has a more proper naming because the function can show and hide HUD components (hence the setPlayer...Visible instead of showPlayer...), and there's no need for two functions that do exaclty the same thing.

Myths

2015-08-14 17:29

viewer   ~~0023932

Would be great to do so.

qaisjp

2016-08-24 04:16

administrator   ~~0025081

Last edited: 2016-08-24 04:17

View 2 revisions

Added in https://github.com/multitheftauto/mtasa-blue/commit/6b3aee3f1b1a904bd754cd9486fd4ac16c0d51dd

Issue History

Date Modified Username Field Change