View Issue Details

IDProjectCategoryView StatusLast Update
0008962Multi Theft Auto : San AndreasCEFpublic2016-09-21 21:38
ReporterXeeeAssigned ToJusonex 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5.3Fixed in Version1.5.3 
Summary0008962: Destroying browser onClientGUIClick result instant crash
Description

http://pastebin.mtasa.com/623121482

TagsNo tags attached.

Activities

Jusonex

2015-07-28 18:47

administrator   ~~0023738

The problem is that you are trying to destroy the underlying browser rather than the gui-browser.

Use the following code to destroy the browser (in case you don't have the gui-browser which would be better):

for k,v in pairs(browsers) do
destroyElement(getElementParent(k))
end

Even though MTA should not crash.

Xeee

2015-07-29 09:30

viewer   ~~0023746

Fixed. Thanks!

Jusonex

2016-09-21 21:37

administrator   ~~0025226

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/71dd9571753696ba690cd5a80b34edb0cff69651

Issue History

Date Modified Username Field Change