View Issue Details

IDProjectCategoryView StatusLast Update
0008949Multi Theft Auto : San AndreasClientpublic2015-07-22 11:42
ReporterruunAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.5.1Fixed in Version1.5.1 
Summary0008949: Hunter sometimes explodes on own projectile.
Description

Hunter sometimes explodes on own projectile.
Video:
https://www.youtube.com/watch?v=18a8BXLO20Q

TagsNo tags attached.

Relationships

related to 0008753 closedmyonlake Destroying a projectile with bindKey results in crash 

Activities

ccw

2015-07-18 07:07

administrator   ~~0023650

https://forum.mtasa.com/viewtopic.php?f=105&t=89467

When did this start happening exactly?

ruun

2015-07-18 08:45

viewer   ~~0023651

It's random, you start shoot without stop and some time you will kill yourself by your explosion.

I tried to find some way to reproduce the bug every time, but without success,
sometimes happens directly, other takes some time.
Some information I have is that began after upgrading to 1.4.1 (i think.)

ruun

2015-07-18 08:52

viewer   ~~0023653

http://unit-games.com/cdn/Untitled_000077.gif
The projectile can collide with hunter model?

sbx320

2015-07-18 09:11

administrator   ~~0023654

Could this be due to the rocket hitting the driver inside the hunter? As far as I know, the projectile hit check explicitly ignores the projectiles creator and in case of a hunter rocket, the creator will be the hunter itself.

However in that case the bug would've always been present.

ccw

2015-07-18 09:50

administrator   ~~0023655

Do other players have to be in the server for this to happen?

rbxf234

2015-07-18 12:36

viewer   ~~0023658

sbx320 is probably right as setElementCollisionsEnabled(localPlayer,false) gets rid of this bug
ccw this can be reproduced even with just you playing, get a hunter rotate it all around and keep shooting a lot of missiles and eventually you will just explode

arranTuna

2015-07-18 13:24

manager   ~~0023659

When you enter a vehicle, GTA SA disables your collisions automatically though which is why things go buggy if you enable your collisions when in a vehicle.

rbxf234

2015-07-18 13:41

viewer   ~~0023663

Not sure to who you are saying this arranTuna, but in my example collisions were true when i entered the hunter, disabling them solved this issue with projectiles causing hunter to explode

arranTuna

2015-07-18 13:45

manager   ~~0023664

getElementCollisionsEnabled might return true when you're in a vehicle but that's because they weren't disabled by script, GTA SA disables player collisions to allow them to enter a vehicle.

Also someone should find out what revisions introduced this bug, so that MTA devs know what caused this to happen.

rbxf234

2015-07-18 13:59

viewer   ~~0023665

clearly then gta sa's way of disabling collisions is not enough and it requires to disable collisions additionally with setElementCollisionsEnabled(localPlayer,false) to avoid this bug until it gets fixed

though tracing which revision caused this bug might be hard

Jusonex

2015-07-21 22:44

administrator   ~~0023708

Please update to the latest nightly (https://nightly.mtasa.com/?mtasa-1.5-latest) and try again.

rbxf234

2015-07-22 00:44

viewer   ~~0023709

it's fixed now

ruun

2015-07-22 00:49

viewer   ~~0023710

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/286366905ee8078004728bcd24eb3a1e7c2024b4

Issue History

Date Modified Username Field Change