View Issue Details

IDProjectCategoryView StatusLast Update
0008945Multi Theft Auto : San AndreasServerpublic2015-08-09 13:34
ReporterarranTunaAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0008945: [1.5] Windows server uses triple Logic thread CPU
Description

Server CPU usage has increased so much that at times Logic thread CPU is at 100% and the server FPS can be as low as 1. This is with only 700 players in-game yet we've handled 1400 players in the past. The usage at times as low as 60% but then can suddenly go as high as 100%.

I cannot see anything in performancebrowser that would indicate what is causing this increase in CPU usage. Lua timing is same as usual.

Logic thread CPU: 94% (Avg: 90%) (Sys: 2%)

Luckily for me I've got a log file which records CPU usage every 1 minute with player count and it shows that CPU usage is TRIPLED what it was before updating to 1.5:

Before updating to 1.5:
Plrs: 687 logic: 31% (Avg: 34%)

Later on after updating to 1.5 and reaching similar player count:
Plrs: 667 logic: 94% (Avg: 81%)

http://pastebin.com/XyUiYgVb

TagsNo tags attached.

Activities

arranTuna

2015-07-16 20:11

manager   ~~0023635

After looking at the 'Server timing' tab for quite some time, nothing specific spikes except .g_pNetServer->DoPulse (); which I've been told is everything combined. So I guess the only way to narrow this down would be adding more subroutines to 'Server timing'.

arranTuna

2015-07-16 21:54

manager   ~~0023640

https://github.com/multitheftauto/mtasa-blue/commit/9179aef8b59c707d6e6ee74108fa994ba30be1eb

Good job!

ccw

2015-07-17 04:05

administrator   ~~0023642

This fix was for the 32 bit server only

topred

2015-08-09 00:02

viewer   ~~0023869

There are 64 bits server fix ?

ccw

2015-08-09 00:54

administrator   ~~0023871

Issue only affected 32 bit Windows server

topred

2015-08-09 02:09

viewer   ~~0023872

Last edited: 2015-08-09 02:21

View 5 revisions

it affect 64 bits too. i dont know if the problem is the same but the reaction is the same, High CPU usage / Low FPS after 1.5 Update.

ccw

2015-08-09 02:31

administrator   ~~0023873

What version of Windows are you using?
What is the server IP?

topred

2015-08-09 12:52

viewer   ~~0023878

Can we speak in Private ?

arranTuna

2015-08-09 13:33

manager   ~~0023881

You can make a comment private and then only a select few with developer and above access level can read it. Just tick the private box below the note box.

Issue History

Date Modified Username Field Change