View Issue Details

IDProjectCategoryView StatusLast Update
0008941Multi Theft Auto : San AndreasClientpublic2015-07-16 16:24
Reporter-GTXAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0008941: setCursorPosition does not work
Description

This function does not work at all, although, it returns true but it seems that cursor isn't moving to certain position.

Steps To Reproduce
  1. Start runcode.
  2. /crun showCursor(true)
  3. /crun setCursorPosition(0, 0)
  4. Try with timers also. Does not work.
Additional Information

Running on Windows 8.1, MTA 1.5 RC-7352.

TagsNo tags attached.

Relationships

related to 0007246 resolvedsbx320 setCursorPosition doesn't work properly 

Activities

arranTuna

2015-07-15 16:51

manager   ~~0023613

It worked in 1.4?

TheMrDadosz

2015-07-15 17:28

viewer   ~~0023614

No, I've tested this on Windows 7, MTA 1.4.1 RC-7350.

TomasitoCaram

2015-07-15 17:34

viewer   ~~0023615

Since 1.4 the cursor position isn't being saved when the cursor hides, showCursor always send the cursor to the center of the screen.

-GTX

2015-07-15 18:15

reporter   ~~0023617

Tried on 1.4 also, it didn't work. Actually, what I tried is showCursor first and then set a timer of 2 seconds to setCursorPosition. It's completely broken.

Jusonex

2015-07-16 16:24

administrator   ~~0023629

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/18d869e26fdd34f9fd6139959b9c3111e61df0e1

Issue History

Date Modified Username Field Change