View Issue Details

IDProjectCategoryView StatusLast Update
0008858Multi Theft Auto : San AndreasScriptingpublic2015-06-23 00:12
ReporterGallardo9944Assigned Toccw 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0008858: [Request] Ability to run a script before other scripts start
Description

This would be very handy to be able to get player's localization without using triggerServerEvent, which runs only when the script starts, but sometimes you need to output serverside messages (in a proper language) when things are still downloading.

TagsNo tags attached.

Activities

RoBben357

2015-05-22 11:16

viewer   ~~0023286

Is there a problem to use a self-created function for this? One possibility would be the ip2c module from the admin panel (admin_ip2c.lua) to determine the country of a player. I see no need to include this as a separate function.

StifflersMom

2015-05-22 17:03

updater   ~~0023287

Agree. We use ip2c from admin panel for serverl years for this. We put the result to the elementData of player so any ressource is able to get the localization by checking the elementData of the player.

sbx320

2015-05-22 19:22

administrator   ~~0023288

The country is not always equal to the selected language. For example I'm using an English client rather than the German one.

MIKI785

2015-05-27 15:27

viewer   ~~0023321

Simply use element data.

Gallardo9944

2015-05-27 20:16

viewer   ~~0023323

MIKI785, please read the description. I'm not able to set element data clientside before scripts are downloaded.

ccw

2015-06-22 05:08

administrator   ~~0023403

Marking this as fixed because 1.5 now has <download_priority_group> as described in https://wiki.multitheftauto.com/wiki/Meta.xml

So features like this can be added using a high priority resource

https://github.com/multitheftauto/mtasa-blue/commit/840ea4da41b9d2b212978181884220790b1a716d

Issue History

Date Modified Username Field Change