View Issue Details

IDProjectCategoryView StatusLast Update
0008815Multi Theft Auto : San AndreasSynchronizationpublic2015-04-07 18:24
Reporterjoaosilva099Assigned Tosbx320 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindowsOS VersionWindows 7
Product Version1.4.1 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008815: Bad position and vehicle hp when warping to players in vehicles
Description

When I warp myself to a vehicle, usually far away, and there is another player on it, I get warped into the sea, or above the sea and the vehicle HP floating around stupid numbers

Steps To Reproduce

Just warp yourself to a player that is in a vehicle

Additional Information

None

TagsNo tags attached.

Activities

joaosilva099

2015-04-07 16:29

viewer   ~~0023190

Last edited: 2015-04-07 16:32

View 2 revisions

Also, if there is no one in the vehicle, you get warped normally, I tested it on a "clean" server (freeroam).
And it started occuring when I updated MTA Client from 7093 to 7152.
Server version is Windows x64 7164.
I updated my MTA to that client version too, and I will still updating until the problem gets fixed

StifflersMom

2015-04-07 16:58

updater   ~~0023192

This seems to be a server issue, I can confirm this with:
Server Linux 32Bit r7156, client 7156 and Client 7164
Server Linux 32Bit r7164, client 7156 and client 7164

Same clients are syncing without problems with server r7069

joaosilva099

2015-04-07 17:10

viewer   ~~0023193

Last edited: 2015-04-07 17:10

View 2 revisions

You know if they already are planning to fix this and what build it will change?
I use Windows 2012 Server to host the x64 MTA server on 7164 build

StifflersMom

2015-04-07 17:16

updater   ~~0023194

joaosilva099 just wait or use a lower server version :)
Server 7069 will run without this Problem. Also, the devs are working on it :)

sbx320

2015-04-07 17:48

administrator   ~~0023195

Sorry. I messed the entire vehicle puresync packet up.

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/a67f2d90cdf2434c3171f8677b0856dc39afcf6e

joaosilva099

2015-04-07 18:13

viewer   ~~0023196

So the problem was clientside?

qaisjp

2015-04-07 18:17

administrator   ~~0023197

Serverside

sbx320

2015-04-07 18:19

administrator   ~~0023198

No, the actual issue was serverside. I was (incorrectly) writing 2 Bytes to the Client, but I read 4 bytes on the Client. This led to packet corruption (since I removed 2 bytes from the Bitstream which weren't supposed to be removed) which caused the reported issues.

ccw has backported this and released a new nightly. r7166 incorporates my fix, so updating your server to r7166 will fix this issue.

joaosilva099

2015-04-07 18:19

viewer   ~~0023199

Last edited: 2015-04-07 18:24

View 2 revisions

Oh, okay, you still updating the x64 windows version on nightly.mtasa.com right?

Issue History

Date Modified Username Field Change