View Issue Details

IDProjectCategoryView StatusLast Update
0008800Multi Theft Auto : San AndreasSynchronizationpublic2015-07-16 17:38
ReporterGallardo9944Assigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0008800: Vehicle components desync when different types
Description

When the server has a particular vehicle (e.g. NRG - a bike), and this vehicle's model is changed clientside (e.g. Infernus), the components will desync - doors will start flapping (if you're not the driver of the vehicle). Same happens to Dumper's loader or Rhino's tower

Steps To Reproduce
  1. Create a vehicle of a non-car type serverside (e.g. NRG-500, id 522)
  2. Change its model CLIENTSIDE (e.g. to Infernus, 411)
  3. Make sure you're not in the vehicle
  4. Admire flapping doors
TagsNo tags attached.

Activities

Gallardo9944

2015-03-23 18:59

viewer   ~~0023115

Last edited: 2015-03-23 19:18

View 2 revisions

Additional information: such problem appeared after pre-final stable update for 1.4, which was released on linux.mtasa.com. Can't say the build number though.

Doing the same, but setting a train clientside, will freeze/crash MTA entirely.

sbx320

2015-03-23 19:20

administrator   ~~0023116

Yup I already have a fix in the makings. The bug is quite obvious, but a bit more complicated.

sbx320

2015-03-24 21:31

administrator   ~~0023117

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/23c44e931b21b92a89106a23ea25bb440d84cc17

Bug was caused by desyncs occuring due to different vehicle models on server/client/remote client causing other parts of the packet being misinterpreted as correct data.

Issue History

Date Modified Username Field Change