Project:
RSS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008751New issuesSynchronizationpublic2015-02-07 02:372017-02-12 16:58
ReporterNoneatme 
Assigned To 
PrioritynormalSeveritytweakReproducibilityrandom
StatusnewResolutionopen 
PlatformOSOS Version
Summary0008751: Various desync and weapon issues
DescriptionSo I'm gonna write this down here for notice.

People on our server are complaining that they get random desync issues.

First, the classic punch-bug: You are holding a gun in your hand but other people see you holding no gun, just your fists.

http://i.imgur.com/jFHt9Tt.jpg [^]

Happens more after doing drive-by as a passenger.

Second, the goggle issue - If you doing a bad animation (I think) while equipping the goggles, this can happen:

http://noneatme.de/vid/wot.webm [^]

The animation goes on and on. The only help is to do a reconnect.
(Also some crashes occur in the making of the video)

Third, weird uptime issues -
The following bugs occurred when MTA is open for like 10+ hours:

1. I was first experiencing this bug in the Open Beta of MTA 1.1 I think. (That time were custom dx fonts and the playSound functions were tested)
There were random stripes going from the center of the screen to the edges when standing right next to a 3d sound. I experienced some stripes again.
You can see a purple stripe in the goggles issue video I posted. @0.01:
http://i.imgur.com/9L4NvRK.jpg [^]

This is really annoying but a MTA restart solves this issue. (for 10 hours)

2. Alpha textures
Textures are getting way too more opacity. It will occur after some time.
http://i.imgur.com/vk0ygWs.png [^]

(No, this is not a script issue. Many people were reporting this bug, it happens after some time playing.)

Fourth, people are driving cars without sitting in them.

Here's a screenshot. In my view the player just "ran" next to the faggio instead of driving it.

http://i.imgur.com/1CIZCJl.jpg [^]

Some players also reported the same bug in a coach, the coach just went all nuts and floated in the air.


I forgot one bug, it was another uptime issue. But nevermind.

I will update this post later to give more informations about the issues.


Greetings

TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0009272closed Synchronization bug with other players in the same server. 

-  Notes
(0022975)
Noneatme (viewer)
2015-02-07 02:57

Here's another video of the goggle bug: http://noneatme.de/vid/wot2.webm [^]
(0023059)
csiguusz (viewer)
2015-03-01 15:26

I've recently performed some experiments with the "punch-bug" on the latest nightly by today. If a player who is shooting in driveby mode enters the streaming of an other player the bug always occurs. setPedWeaponSlot either on client or server side didn't help. But a giveWeapon with 0 ammo on the drivebying player when he streams in others can solve the problem, as a workaround.
(0025670)
Bonus1702 (viewer)
2017-02-12 16:58

The "punch-bug" can come in other ways, too - not only after driveby.

My server doesn't allow driveby, realdrive is off.
I had the bug many times after spawning the ped right after he died in a fight and giving him the weapons again.

- Issue History
Date Modified Username Field Change
2015-02-07 02:37 Noneatme New Issue
2015-02-07 02:57 Noneatme Note Added: 0022975
2015-03-01 15:26 csiguusz Note Added: 0023059
2016-06-20 18:41 arranTuna Relationship added has duplicate 0009272
2017-02-12 16:58 Bonus1702 Note Added: 0025670


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker