View Issue Details

IDProjectCategoryView StatusLast Update
0008729New issuesServerpublic2018-09-02 18:22
Reporterme_mueedAssigned Tomyonlake 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionunable to reproduce 
Platform64-bitOSWindowsOS Version8.1 Pro
Summary0008729: Players sometimes are unable to log into their account
Description

Some players at times can not log in to their accounts. Trying to log in gives out the error - 'Account already in use'. Player list (Tab) shows a player using that account with the same nick and country of the account owner with ping 0. Tracking down that player using /whois leads to the original account owner.

Additional Information

Kicking out the player (Ping 0) allows the original owner to log in and fixes the problem temporarily until someone else faces this problem.

TagsNo tags attached.

Relationships

related to 0006930 resolvedccw Multi Theft Auto : San Andreas Client disconnects but player element remains indefinitely 

Activities

Grafu

2015-01-18 15:25

viewer   ~~0022885

It seems the player elements are not properly destroyed when they disconnect under some exotic condition. It happens to us since we updated the server to 1.4.1. I remember there was a similar issue with some 1.3 version.

Gallardo9944

2015-01-19 20:36

viewer   ~~0022896

Probably related to "CD36: Join Flood" which I myself got on my server after leaving the game with ALT+F4 and coming back in 2 hours. Looks like the element or dead connection stayed there which lead to problems.

sbx320

2015-01-19 20:50

administrator   ~~0022897

Does this still happen for you after r7028?

(http://bugs.mtasa.com/view.php?id=6930#c22893)

JBoy

2015-02-05 11:17

viewer   ~~0022971

checking getNetworkStats(player) to see if it's false fixes the issue. The code below will help with that.

function checkPlayerNetwork()
for k,v in ipairs(getElementsByType("player")) do
if not getNetworkStats(player) then
outputServerLog("[PNetwork] Player's connection's dead. Kicking...")
kickPlayer(v)
end
end
end
setTimer(checkPlayerNetwork,5000,0)

Issue History

Date Modified Username Field Change