View Issue Details

IDProjectCategoryView StatusLast Update
0008719Multi Theft Auto : San AndreasScriptingpublic2018-07-24 04:04
ReporterSeddoAssigned Toccw 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.4 
Target VersionFixed in Version1.4 
Summary0008719: setVehicleComponentRotation in 1.4.0.7000
Description

I have a bug in new MTA version 1.4.0.7000 with setVehicleComponentRotation function. I have a custom cars on my server, steering wheel is separate object with its own dummy. With setVehicleComponentRotation function i made it rotate left and right. In MTA version 1.4.0.6968 it works perfectly, but in new update it is broken. Function rotates object on an X and Y axis, but ignores Z axis.
I think it will be easier to understand what I mean by a picture. Thih bug have all players update to version 1.4.0.7000.

TagsNo tags attached.

Relationships

related to 0007421 closed setVehicleComponentRotation has no effect for some vehicle nodes 

Activities

ccw

2015-01-13 02:58

administrator   ~~0022858

Please try with latest nightly r7013:
http://nightly.mtasa.com/mtasa-1.4-rc-7013-20150113.exe

Seddo

2015-01-15 18:41

viewer   ~~0022866

Its working! Thank you very much!

qaisjp

2015-01-16 18:18

administrator   ~~0022868

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=7013

Kenix

2015-01-18 01:13

updater   ~~0022883

Last edited: 2015-01-18 01:28

View 7 revisions

Not fixed. I have problems with my old script.

Steps to reproduce:

  1. Download test_bug resource: https://www.dropbox.com/s/lswv6ikodj7e830/test_bug.zip?dl=0
  2. Download old mta version: http://nightly.mtasa.com/mtasa-1.4-full_rc-6815-20140819.exe (r6815 for example)
  3. /start test_bug
  4. /start freeroam (f1->create->rhino->get in)
  5. You will see a white line.

And now download newest mta version: http://nightly.mtasa.com/mtasa-1.4.1-full_rc-7028-20150117.exe

Add second argument "base" with "root" ( "root" is not compatible - doesn't help ) to functions getVehicleComponentPosition/Rotation in resource test_bug and follow again steps 1, 2.

ccw

2015-01-18 03:55

administrator   ~~0022884

Thanks for the example resource. The problem is before r6974 the component rotations went the wrong way (i.e. opposite to the vehicle rotations). This has been corrected, so you'll have to modify any scripts written before r6974 that use component rotations.

I've updated the wiki with this bombshell.

Kenix

2015-01-18 21:15

updater   ~~0022890

Last edited: 2015-01-18 21:16

View 3 revisions

Big thanks to you ccw, now i have rewrited and all works fine. (with tank target - old script)

xNob0dy

2015-01-21 19:44

viewer   ~~0022900

i'm trying to set wheels rotation, but dont work, is a bug or what ?

lopezloo

2015-01-21 22:36

developer   ~~0022901

@xNob0dy
Yes, see #7421

Issue History

Date Modified Username Field Change