View Issue Details

IDProjectCategoryView StatusLast Update
0008686Multi Theft Auto : San AndreasScriptingpublic2014-12-23 10:25
ReporterAlexTMjugadorAssigned Tosbx320 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.4 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008686: setWeaponFlags(weapon, "flags") always returns false, but getWeaponFlags(weapon, "flags") works correctly
Description

When using setWeaponFlags on a weapon element and modifying the "flags" flag, the function returns false even if passed a valid weapon element and 8 booleans.

getWeaponFlags returns, however, the new expected values.

Steps To Reproduce

Simply execute this with runcode:

crun weapon = Weapon("m4", localPlayer.position) -- Create the weapon to test

crun weapon:setFlags(weapon, "flags", false, false, false, false, false, false, false, false) -- Returns false, but it shouldn't

crun weapon:getFlags("flags")
Command results: false [boolean], false [boolean], false [boolean], false [boolean], false [boolean], false [boolean], false [boolean], false [boolean] -- Returns the expected result

TagsNo tags attached.

Activities

AlexTMjugador

2014-12-21 17:13

viewer   ~~0022710

Last edited: 2014-12-21 17:23

View 3 revisions

Tested in Multi Theft Auto v1.4-release-6968 client and server.

And I wrote a little typo in the second command to test, sorry :P. It should be as follows:
crun weapon:setFlags("flags", false, false, false, false, false, false, false, false)

Anyway, the issue is still reproduceable.

sbx320

2014-12-23 10:25

administrator   ~~0022716

Fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6981

Issue History

Date Modified Username Field Change