View Issue Details

IDProjectCategoryView StatusLast Update
0008675Multi Theft Auto : San AndreasServerpublic2015-11-02 14:13
ReporterStifflersMomAssigned Toccw 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux x64OSOS Version
Product Version1.5 
Target Version1.5.1Fixed in Version1.5.1 
Summary0008675: Uptime issues (more than 49 days)
Description

server uptime: 49 days 18 hours 30 minutes 28 seconds

Endless timers seems to end at 49 days.
Traffic Lights aren't switched anymore

Steps To Reproduce

create a ressource which using an endless timer, wait for 49 days :-)

TagsNo tags attached.

Activities

StifflersMom

2014-12-11 09:44

updater   ~~0022667

forgot the server version:
MTA:SA Server v1.4-release-6892

StifflersMom

2014-12-11 11:23

updater   ~~0022668

For the sync issues, which are probably fixed by ccw, we made 2 funny videos:

https://www.youtube.com/watch?v=5EIZQaUn8jA
https://www.youtube.com/watch?v=l23LEu0hK3s

After that, we have restarted the server. It was unusable :)

Dutchman101

2014-12-11 13:16

updater   ~~0022669

https://code.google.com/p/mtasa-blue/source/detail?r=6965

StifflersMom

2014-12-11 15:40

updater   ~~0022670

Last edited: 2014-12-11 15:41

View 2 revisions

I know - The Video with the towtruck shows a sync issue, which is probably not fixed yet: I have recorded the video from the passenger seat of the towtruck, the vehicle is not "unoccupied" - Also, it's not only the towtruck. I would name it "passenger sync sometimes is broken after 49 days" :)

W

2015-02-22 13:11

viewer   ~~0023032

Can confirm, just happened on 32-bit r7060 on Linux at about 49 hours 17 hours. After connecting to server, it accepted 2-3 commands and then no more command could be entered (even start or restart). Half of the players had ping=0.

StifflersMom

2015-06-03 10:31

updater   ~~0023347

Last edited: 2015-06-04 19:30

View 2 revisions

MTA:SA Server v1.4.1-release-7069 x64:
server uptime: 49 days 17 hours 14 minutes 25 seconds
Just reached the 49 days wrap again.
Endless timers ended at 49 days, 17 hours, 2 minutes, 47 seconds again.
Vehicle respawning and traffic lightss are fixed :)

Edit: Also endless timers, which are restarted 1 day before the "49day issue" is reached, are affected.

StifflersMom

2015-10-07 15:14

updater   ~~0024108

MTA:SA Server v1.5-release-7432 x64:
server uptime: 51 days 1 hours 22 minutes 5 seconds

I can't reproduce anything of this issue, great :)

Xenius

2015-10-12 20:22

viewer   ~~0024113

forgot x64
use v1.5-release-7444 x32
after 80 days uptime -> no issues

Issue History

Date Modified Username Field Change