View Issue Details

IDProjectCategoryView StatusLast Update
0008645Source patchesClientpublic2014-12-31 14:40
ReporterarranTunaAssigned Toqaisjp 
PrioritynormalSeveritytrivialReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0008645: Patch for #6701 ([Request] client-side forcePlayerMap)
Description

It's simple.

Edit: <qaisjp> it doesn't sync with the server

I need to look into making isPlayerMapForced get updated on the server when client function is used.

Edit: I can't find any existing system to use that would do the above as there is no similar client side function that sends a state like this to server and I suppose it's not really necessary but then again this whole patch is not really necessary as scripters can easily get around the server side only limitation.

So it doesn't really matter whether this patch is added or not.

TagsNo tags attached.

Relationships

related to 0006701 resolvedqaisjp Multi Theft Auto : San Andreas [Request] client-side forcePlayerMap 

Activities

qaisjp

2014-11-22 01:38

administrator   ~~0022542

Just tested the patch. It works (except server info isn't synced, so forcing on the server and then forcing false on the client will keep the server thinking its forced)

x86

2014-12-01 09:32

administrator   ~~0022624

This patch is OK. The server doesn't need to know this because this happens and stays client-side. All other functions work like this also.

qaisjp

2014-12-27 20:49

administrator   ~~0022733

added in https://code.google.com/p/mtasa-blue/source/detail?r=6985

Issue History

Date Modified Username Field Change