View Issue Details

IDProjectCategoryView StatusLast Update
0008643Multi Theft Auto : San AndreasClientpublic2014-11-23 22:06
ReporterqaisjpAssigned Toqaisjp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008643: getVehicleController fails for trains
Description

cv tram
--get in
run getRandomPlayer().vehicle.controller

false

TagsNo tags attached.

Activities

Tosfera

2014-11-20 21:39

viewer   ~~0022535

I just tried it, and without the OOP style it works perfectly.

qaisjp

2014-11-21 00:20

administrator   ~~0022536

I should mention I used warpPedIntoVehicle. I'll provide proper code to reproduce tomorrow.

lopezloo

2014-11-21 16:27

developer   ~~0022538

Last edited: 2014-11-21 16:33

View 4 revisions

Can't reproduce.
run veh = Vehicle(449, 0, 0, 0)
run warpPedIntoVehicle(getRandomPlayer(), veh)
run getRandomPlayer().vehicle.controller -- returns player element

v6935

arranTuna

2014-11-23 16:47

manager   ~~0022562

crun getVehicleController(getPedOccupiedVehicle(localPlayer))
returns false

srun getVehicleController(getPedOccupiedVehicle(getRandomPlayer()))
returns true

qaisjp

2014-11-23 17:21

administrator   ~~0022566

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6946

Issue History

Date Modified Username Field Change