View Issue Details

IDProjectCategoryView StatusLast Update
0008629Multi Theft Auto : San AndreasClientpublic2015-07-16 17:37
ReporterqaisjpAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformv1.4-release-6918OSwindowsOS Version8.1 pro
Product Version1.4 
Target Version1.5Fixed in Version1.5 
Summary0008629: Destroying vehicle when exiting it causes issues
Description

See the video below.
Destroying your vehicle when you're leaving it causes you to be invisible and disables movement controls.
When in this state, recreating a vehicle and warping yourself into it results in your player element to be shown but keeps it in the original position at a stuck animation. Moving the vehicle shows a clear "desync" between camera targetting and player position.

Changing to another skin fixes the bug. "Changing" to the same skin (you're currently cj, and you do /ss 0) doesn't do anything.

Steps To Reproduce

http://youtu.be/vh6NGgUPBjM
warp ped into a newly created vehicle
bind a key to destroy the vehicle
press enter, mid-getout animation press the destroy key

TagsNo tags attached.

Relationships

has duplicate 0008677 closed New issues player element hides, if a vehicle is destroyed while exiting the vehicle 
has duplicate 0008685 closed New issues destroyElement causes player to be deleted 

Activities

Dutchman101

2014-11-16 20:16

updater   ~~0022469

This happened to me yesterday, but actually when i triggered exiting with an vehicle on fire. It looked like MTA was thinking i was out already, instead of getting killed when i finished the exit anim, the car despawned (like usual on some gamemodes; despawn as it looks like the already-blown vehicle catches fire again) and I was left like the video showed (invisible) being unable to move or do anything till respawn

qaisjp

2014-11-16 20:18

administrator   ~~0022470

I should also mention that this bug didn't exist in 1.0.4.

castillo14

2014-12-12 20:45

viewer   ~~0022678

This is happening a lot in my server.

Server version: 1.4.0-9.06964.0
Client version: 1.4-release-6963

mahmoudembaby

2014-12-14 16:43

viewer   ~~0022685

I got this too under.
It can be abuse-able for RPG servers which have staff skin.
The player's skin is changed for the next skin ID and some text are outputed to them via chatbox "TASK_SIMPLE....".
Server: 1.4.0-9.06963.0
Client: 1.4-release-6966

AboShanab

2014-12-20 19:45

viewer   ~~0022707

any new news ?
ccw ?
jusonex96 ?

Dutchman101

2014-12-20 22:20

updater   ~~0022709

''When in this state, recreating a vehicle and warping yourself into it results in your player element to be shown but keeps it in the original position at a stuck animation. Moving the vehicle shows a clear "desync" between camera targetting and player position.''

http://bugs.mtasa.com/view.php?id=8653

In there something similar happens; the player element takes distance from vehicle as it stucks in an anim. Not neccesarily related to this issue, but the cause may be related as it has that same sign

qaisjp

2015-04-06 02:10

administrator   ~~0023179

Fixed in https://github.com/multitheftauto/mtasa-blue/commit/7e3e33033f3264463a7fe5a665074b65e59ad56c

Issue History

Date Modified Username Field Change