View Issue Details

IDProjectCategoryView StatusLast Update
0008622Multi Theft Auto : San AndreasClientpublic2014-11-16 11:58
ReporterKenixAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindows 7OS Version
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008622: dxDrawRectangle draws with different width size
Description

Look at screenshot.

Steps To Reproduce

I_SCREEN_X, I_SCREEN_Y = guiGetScreenSize();

addEventHandler( "onClientRender", root,
function()
for i = 1, 70 do
dxDrawRectangle(
( 0.94 - ( i 0.003 ) ) I_SCREEN_X, 0.903 I_SCREEN_Y,
0.001
I_SCREEN_X, 0.035 * I_SCREEN_Y
);
end
end
);

Additional Information

Multi Theft Auto v1.4-release-6882

TagsNo tags attached.

Activities

arranTuna

2014-11-15 17:43

manager   ~~0022375

Because the width is 1.28 and the height is 35.84? If you'd have debugged your script you'd have seen that.

Kenix

2014-11-15 21:40

updater   ~~0022389

Last edited: 2014-11-15 21:55

View 4 revisions

Code for reporoduce updated.

ccw

2014-11-15 22:09

administrator   ~~0022390

This is caused by dxDrawRectangle rounding the start and end pixels positions. I did have a patch to add sub-pixel positioning (like dxDrawText). I'll see if I can find it.

lopezloo

2014-11-16 05:31

developer   ~~0022428

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6931

Issue History

Date Modified Username Field Change