View Issue Details

IDProjectCategoryView StatusLast Update
0008612Multi Theft Auto : San AndreasVehiclespublic2014-11-09 14:02
ReporterjhxpAssigned ToCazomino05 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 8.1 ProOS Versionx64 Update 1
Product Version1.4 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008612: [!!!Steam Update Crash!!!] Crash while switching radio stations
Description

Game seems to crash if you switch radio stations a few times while being in a vehicle.

I'm using the GTA:SA Steam release, so this crash might be related to the recently released update for GTA:SA on Steam, which removed some of the songs from the game:
http://steamcommunity.com/app/12120/discussions/0/613941122679191562/
http://steamcommunity.com/app/12120/discussions/0/34096318984412375/

Steps To Reproduce
  1. Start a local server and run 'play' or freeroam gamemode.
  2. Get in a vehicle.
  3. Switch radio stations a few times, until you get to Bounce FM or K-Jah West. The game will crash immediately.
Additional Information

Version = 1.4-release-6902.0.000
Time = Sat Nov 08 12:18:51 2014
Module = d:\gry\steam\steamapps\common\grand theft auto san andreas\gta_sa.exe
Code = 0xC0000094
Offset = 0x000F1464

EAX=00009421 EBX=00862D70 ECX=00000000 EDX=00000000 ESI=00B606CC
EDI=219ED7A0 EBP=219ED680 ESP=1C3EFF40 EIP=004F1464 FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

TagsNo tags attached.

Activities

Cazomino05

2014-11-08 13:09

reporter   ~~0022275

Last edited: 2014-11-08 13:16

View 2 revisions

new steam versions are currently considered unsupported due to the unknowns in what has changed, someone mentioned that songs have been removed which might be related to this.

Hopefully over the next few days/weeks we will find out exactly what changed and why so we can go from there and see if native support is an option or not.

Cazomino05

2014-11-08 13:28

reporter   ~~0022276

Last edited: 2014-11-09 10:38

View 3 revisions

<GodFather> yeah I copied the whole audio folder and it doesn't crash on switching anymore
just spoke to GodFather who confirmed this is related to the new steam update modifying the audio archives, the previous archives are fine so I'll escalate this to 1.4.1 and try and figure out what to do.

Song files removed from the update are:
Playback FM: Critical beatdown

K-DST: Running Down a Dream, Woman to Woman

Bounce FM: You Dropped a Bomb On Me, Yum Yum, Running Away

Radio Los Santos: I Don't give a ...., Express yourself (N.W.A)

Radio X: Hell raiser, Killing In The Name Of

K-Jah West: Ring my Bell, Don't Let It Go To Your Head

Master Sounds 98.3: Express Yourself (Charles Wright & the Watts 103rd Street
Rhythm Band), Rock Creek Park, Funky President, The Grunt, Soul Power '74, The
Payback
Affected files

einheit-101

2014-11-09 08:37

reporter   ~~0022283

Steam is sooo useless, unnecessary piece of garbage....
Removing music?? Hello? I hope it gets fixed :/

Cazomino05

2014-11-09 10:38

reporter   ~~0022284

Leaving this open for a while in case I missed a song or something but it should be fixed in r6917 - https://code.google.com/p/mtasa-blue/source/detail?r=6917

jhxp

2014-11-09 14:01

administrator   ~~0022292

Last edited: 2014-11-09 14:02

View 2 revisions

Doesn't crash for me anymore (r6918).
Good job.

Issue History

Date Modified Username Field Change