View Issue Details

IDProjectCategoryView StatusLast Update
0008605Multi Theft Auto : San AndreasClientpublic2014-12-06 20:07
ReporterarranTunaAssigned Tosbx320 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008605: setObjectBreakable causes infinite streaming range for some objects
Description

I was very far out to sea and noticed that some objects on the other side of the map were still streamed in, turns out setObjectBreakable causes it.

-- Be far away from Grove Street
crun setElementPosition(localPlayer, -1311, -152, 14)
-- Make 500 boxes at Grove Street
crun for i=1, 500 do createObject(1440, 2488, -1659, 13) end
-- This will return 0:
crun #getElementsByType("object", root, true)
restart runcode
-- Make 500 unbreakable boxes at Grove Street
crun for i=1, 500 do setObjectBreakable(createObject(1440, 2488, -1659, 13), false) end
-- This will return 500:
crun #getElementsByType("object", root, true)

setObjectBreakable isn't important though since we can cancel onClientObjectBreak instead.

TagsNo tags attached.

Issue History

Date Modified Username Field Change