View Issue Details

IDProjectCategoryView StatusLast Update
0008600Multi Theft Auto : San AndreasGUIpublic2015-01-10 00:00
ReporterJBoyAssigned Tosbx320 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.4 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008600: Using gsub on certain chars causes a graphical glich
Description

Well, it seems that when I use gsub("%W","") on a string which contains special chars such as "£", it'll show up as the image below if you set the results with guiSetText()

Steps To Reproduce

local string = "Hi, I have lots of £££"
string = string:gsub("%W","")
guiSetText(label,string)

TagsNo tags attached.

Relationships

related to 0008606 resolvedsbx320 Add support for unicode gsub, gmatch, find, match and reverse 

Activities

ccw

2014-11-02 17:00

administrator   ~~0022253

£ is a unicode character in MTA, so it won't work proper with string.gsub

Gallardo9944

2014-11-02 18:05

viewer   ~~0022255

http://forum.mtasa.com/viewtopic.php?f=148&t=74970

JBoy

2014-11-04 20:29

viewer   ~~0022262

Thx for the link, Gallardo.

arranTuna

2014-11-11 23:57

manager   ~~0022338

I did what you said but can't reproduce it:

crun lab = guiCreateLabel(400, 400, 400, 20, "aaaa", false)
crun string = "Hi, I have lots of £££"
crun string = string:gsub("%W","")
crun guiSetText(lab, string)

The label says "HiIhavelotsof" there is no dodgy characters in it.

lopezloo

2015-01-09 23:56

developer   ~~0022816

Fixed in r7001
https://code.google.com/p/mtasa-blue/source/detail?r=7001

Issue History

Date Modified Username Field Change