View Issue Details

IDProjectCategoryView StatusLast Update
0008574Multi Theft Auto : San AndreasScriptingpublic2014-10-25 21:33
Reporterrbxf234Assigned ToCazomino05 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformMTA 1.4OSWindowsOS Version7
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008574: destroying vehicle upon onVehicleStartExit makes any vehicle un-enterable
Description

if you destroy a vehicle on event ( onVehicleStartExit ) it will be like the person is still in the vehicle but as the vehicle doesn't exist anymore it will be impossible for player to exit the non-existant vehicle(or enter any existant vehicles)

Steps To Reproduce

function existanceBug()
destroyElement(source)
end
addEventHandler("onVehicleStartExit",root,existanceBug)

TagsNo tags attached.

Activities

einheit-101

2014-10-09 02:21

reporter   ~~0022153

A similar issue occurs when using "warpPedIntoVehicle" with "getControlState("enter_exit")" - the Player will immediately move out of the vehicle he just got warped in (because of the enter_exit control) and MTA thinks, the player is still in the vehicle. You should add a small timer to avoid such issues.

Cazomino05

2014-10-25 21:32

reporter   ~~0022216

fixed in r6895 - https://code.google.com/p/mtasa-blue/source/detail?r=6895#

Issue History

Date Modified Username Field Change