View Issue Details

IDProjectCategoryView StatusLast Update
0008549Multi Theft Auto : San AndreasScriptingpublic2014-10-05 14:54
ReporterAboShanabAssigned ToJusonex 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformWindows 8.1OS8.1OS Versionx32
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008549: unbindKey doesn't work with lowercase letters
Description

try this code
srun setElementData ( getPlayerFromName ( "#i[A]boShanab~/>" ), "Language", "Arabic" )
srun bindKey ( getPlayerFromName ( "#i[A]boShanab~/>" ), "R", "down", "chatbox", getElementData ( getPlayerFromName ( "#i[A]boShanab~/>" ), "Language" ) )
Now It's work with bindkey ^ and return true.
srun unbindKey ( getPlayerFromName ( "#i[A]boShanab~/>" ), "R", "down", "chatbox", getElementData ( getPlayerFromName ( "#i[A]boShanab~/>" ), "Language" ) )
Now It's not work and return true.
Proplem With unbindKey.

TagsNo tags attached.

Activities

AboShanab

2014-09-23 20:06

viewer   ~~0022044

Last edited: 2014-09-23 20:06

View 3 revisions

I forget This Note. if you change Language and use unbindKey and bindKey it's work, but sometimes not work.

qaisjp

2014-09-23 23:43

administrator   ~~0022045

unbindKey(name, "R", "down", "chatbox") should work without the extra arg.

AboShanab

2014-09-25 13:07

viewer   ~~0022049

Last edited: 2014-09-25 13:25

View 3 revisions

yes i know it but it not works sometimes, i will make video for this bug.

AboShanab

2014-09-30 14:43

viewer   ~~0022112

Show This Video.
http://youtu.be/zPaAfefQOhw

AboShanab

2014-09-30 17:14

viewer   ~~0022113

MTASA Ver. 6873.

TAPL

2014-09-30 18:58

viewer   ~~0022114

"This video is private."

AboShanab

2014-09-30 20:09

viewer   ~~0022115

Sorry, Check Now.

qaisjp

2014-09-30 20:12

administrator   ~~0022116

It seems like a scripting error to me.

AboShanab

2014-09-30 20:31

viewer   ~~0022117

hahahaha, if proplem from scripting, why on one test and two and three and four and five it's work 100%, but in other test not work..

W

2014-10-01 10:49

viewer   ~~0022118

srun unbindKey ( getPlayerFromName ( "#i[A]boShanab~/>" ), "R", "down", "chatbox", getElementData ( getPlayerFromName ( "#i[A]boShanab~/>" ), "Language" ) )

It surely is a scripting error. Even, if the fourth argument were treated as a function, it would be an anonymous function, different than the one used in bindKey().

Drop the fourth argument. It's not a bug.

AboShanab

2014-10-01 11:25

viewer   ~~0022119

proplem in unbindKey(name, "R", "down", "chatbox")
and unbindKey ( getPlayerFromName ( "#i[A]boShanab~/>" ), "R", "down", "chatbox", getElementData ( getPlayerFromName ( "#i[A]boShanab~/>" ), "Language" ) )
all have proplem.

AboShanab

2014-10-01 18:44

viewer   ~~0022121

ccw ?

AboShanab

2014-10-02 16:06

viewer   ~~0022122

Last edited: 2014-10-02 16:57

View 2 revisions

the problem when i choose the " arabic language " for example and change the language to " germany " then i change the language to " arabic " again , in chat that does not change

AboShanab

2014-10-03 02:05

viewer   ~~0022129

someone can confirm it..

Jusonex

2014-10-05 14:40

administrator   ~~0022146

Last edited: 2014-10-05 14:53

View 2 revisions

It works if you use a lowercase 'r' instead of an uppercase.

EDIT: Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6878

Issue History

Date Modified Username Field Change