View Issue Details

IDProjectCategoryView StatusLast Update
0008547Multi Theft Auto : San AndreasClientpublic2014-12-22 14:34
ReporterStifflersMomAssigned Tosbx320 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.4.1 
Summary0008547: Towtruck Crashes
Description

While trying a client script work around for issue 1655 (Trailer desync), this code crashes with towtruck at the 2nd stream in (always).

The funny part: This works with linerunner and trailers :-)

http://pastebin.com/QmTcxhvX

Steps To Reproduce

Try this client side http://pastebin.com/QmTcxhvX

stream out with a 2nd player and stream back in (teleport).

Client of 2nd player crashes with
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x002AC57C

on 2nd stream in.

TagsNo tags attached.

Activities

StifflersMom

2014-09-22 21:26

updater   ~~0022040

Multi Theft Auto v1.4-release-6859 is the client version, I forgot...

Dutchman101

2014-09-25 11:12

updater   ~~0022048

Last edited: 2014-10-25 18:55

View 3 revisions

This just happened without the specific script, just Freeroam which had spawned over 15 towtrucks.. and while flying over them, (players that spawned them on the ground) and crash..

Version = 1.4-release-6871.0.000
Time = Thu Sep 25 11:10:15 2014
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x002AC57C

EAX=0028FC3C EBX=00000000 ECX=15CE0658 EDX=00863C40 ESI=15CDFC40
EDI=00000220 EBP=00000000 ESP=0028FBE8 EIP=206E6565 FLG=00010202
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

crashdump: https://mega.co.nz/#!EQFGBTJY!L8fjdunlNOuNhi7oYFbNIf-B-ZpMZ7sh7SBbTFlPej0

dumptrace/stack: http://pastebin.com/ViYRWjJY

StifflersMom

2014-10-25 10:28

updater   ~~0022213

It's not only while reattaching anything to a towtruck with script.
If you run freeroam only, spawn a towtruck, spawn any car, attach the car to the towtruck. If you warp into the towtruck as passenger, you nearly always get
Version = 1.4-release-6893.0.000
Time = Sat Oct 25 10:12:50 2014
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x002AC57C

EAX=0028FC38 EBX=00000000 ECX=1589E900 EDX=00863C40 ESI=158900D8
EDI=00000220 EBP=00000000 ESP=0028FBE4 EIP=206E6565 FLG=00010206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

At this time, we can only solve this by disabling the towtruck :-(

Dutchman101

2014-10-25 18:49

updater   ~~0022215

That, and it also happens randomly when towtrucks are around, disabling them can be needed due to the chance you crash if towtrucks involve your game.

I would see it as a priority because of that, can it be caused by this?:
https://code.google.com/p/mtasa-blue/source/detail?r=6528

ccw

2014-11-01 14:35

administrator   ~~0022252

I can't reproduce this. Can someone make a script which does everything to cause the crash?

StifflersMom

2014-11-10 16:07

updater   ~~0022307

Last edited: 2014-11-10 16:25

View 2 revisions

Yeah. Just 3 lines of runcode and stream out - Crash. Reproduce:
set your player position very far away from 0,0,0

srun tt=createVehicle(525,0,0,3)
srun tr=createVehicle(411,0,10,3)
srun attachTrailerToVehicle(tt,tr)

set your player position to 0,20,4

take a jetpack and fly away. If the vehicle /trailer streams out:

Version = 1.4-release-6918.0.000
Time = Mon Nov 10 16:05:35 2014
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x002AC57C

EAX=0028FC38 EBX=00000000 ECX=15488CE0 EDX=00863C40 ESI=154882C8
EDI=00000220 EBP=00000000 ESP=0028FBE4 EIP=206E6565 FLG=00010202
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Always reproduceable for me.

Edit: There is one very funny detail: You have to fly backward (with S key). If you fly forward and / or the vehicles are not seen at screen, it doesn't crash.

Dutchman101

2014-11-10 17:10

updater   ~~0022308

Last edited: 2014-11-10 17:10

View 2 revisions

it was debugged by sbx320..

the cause: destroyed vehicle remains in the attached pointer

there's an invalid vehicle in the attached vehicle pointer, but it's unknown where it came from

in some way related to the trailer being deleted (sa-internally) but not reattached upon streaming in

I myself think it can be related to the 2 recent commits, the trailer fix by jusonex, or the infinite recursion fix on the attach link what would've been an crashfix (r6528)

Dutchman101

2014-11-16 00:15

updater   ~~0022391

Any more info/new insights on this before it becomes a top-occurance crash? pretty annoying..

Dutchman101

2014-11-23 22:20

updater   ~~0022581

Last edited: 2014-11-23 22:20

View 2 revisions

It just happened again (same offset) but weird enough there were no towtrucks/trailers anywhere near me as far i know

Version = 1.4-release-6938.0.000
Time = Sun Nov 23 22:18:05 2014
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xC0000005
Offset = 0x002AC57C

EAX=0028FC30 EBX=00000000 ECX=160CC700 EDX=00863C40 ESI=160CBCE8
EDI=00000220 EBP=39D85C44 ESP=0028FBDC EIP=206E6565 FLG=00210206
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

That would mean it can also happen in another way somehow

StifflersMom

2014-11-25 10:25

updater   ~~0022596

I tested many things around this including trains - Only the towtruck causes this for me.

sbx320

2014-12-22 14:34

administrator   ~~0022715

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6979.

This was caused by the trailer being streamed out while the towing vehicle was still streamed in. Since we're forcefully streaming in/out trailers upon stream in/out of the towing vehicle, the solution is to stop trailers from being streamed out by the streamer.

Issue History

Date Modified Username Field Change