View Issue Details

IDProjectCategoryView StatusLast Update
0008523Multi Theft Auto : San AndreasScriptingpublic2018-09-02 20:45
Reportereinheit-101Assigned Toqaisjp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.1 
Target Version1.5.6Fixed in Version1.5.6 
Summary0008523: getVehicleNameFromModel does NOT return false if the provided model ID doesn`t exist
Description

getVehicleNameFromModel returns an empty string, if i provide a fictional model ID.

Steps To Reproduce

vname = getVehicleNameFromModel(1234)
outputChatBox("Vehicle: " ..vname)

... this will output:
"Vehicle: "

TagsNo tags attached.

Relationships

duplicate of 0007444 closed New issues getVehicleNameFromModel doesn't return false when it fails 

Activities

qaisjp

2014-09-07 20:59

administrator   ~~0021970

Should be fixed in http://code.google.com/p/mtasa-blue/source/detail?r=6850
Please mark as resolved.

ccw

2014-09-13 21:17

administrator   ~~0022015

What about deprecating getVehicleName/getVehicleNameFromModel and adding getModelName/getElementModelName

qaisjp

2014-09-13 21:18

administrator   ~~0022016

Yes.

Fabio(GNR)

2014-10-20 00:11

viewer   ~~0022188

duplicate of http://bugs.mtasa.com/view.php?id=7444

myonlake

2018-07-08 17:02

updater   ~~0026655

Merged in https://github.com/multitheftauto/mtasa-blue/commit/289313a7b1f23a9d8b73c80dc4c3fcbb2f0e6077

Buildinfo: https://buildinfo.mtasa.com/?SHA=289313a7b1f23a9d8b73c80dc4c3fcbb2f0e6077

Issue History

Date Modified Username Field Change