View Issue Details

IDProjectCategoryView StatusLast Update
0008484Multi Theft Auto : San AndreasVehiclespublic2014-08-22 20:37
ReporterMrTastyAssigned Toccw 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.4.1Fixed in Version1.4.1 
Summary0008484: Rumpo > Front bumper rotation bugged after fixVehicle()
Description

Rumpo's front bumper is rotated 180° (towards the center of the model) on the Z axis

Steps To Reproduce

Spawn Rumpo
Check the front bumper - should look normal
/run fixVehicle( --[[ the Rumpo van vehicle element ]] )
Works also with Freeroam's /repair

TagsNo tags attached.

Activities

MrTasty

2014-08-21 22:55

viewer   ~~0021830

Last edited: 2014-08-21 23:04

View 3 revisions

There's also a problem with Romero's trunk opening rotations, but that's a different issue I guess.
EDIT: http://bugs.mtasa.com/view.php?id=8485 for Romero issue

Cheez

2014-08-22 09:53

viewer   ~~0021836

And also the Bandito's engine wheel gets rotated when you fix the vehicle.
http://i.imgur.com/uAhTmJD.png

AlexTMjugador

2014-08-22 10:27

viewer   ~~0021838

In my scripts I usually don't use fixVehicle because of this and other bugs. Instead I use setElementHealth, setVehicleLightState, setVehiclePanelState and setVehicleDoorState for a complete repair, and it works fine.

lopezloo

2014-08-22 20:13

developer   ~~0021840

Fixed in https://code.google.com/p/mtasa-blue/source/detail?r=6819

Issue History

Date Modified Username Field Change