View Issue Details

IDProjectCategoryView StatusLast Update
0008474Multi Theft Auto : San AndreasScriptingpublic2014-08-19 19:36
ReporterAlexTMjugadorAssigned Tosbx320 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platform1.3.5-release-6596.0.000OSWindows 8.1OS Version
Product Version 
Target VersionFixed in Version1.4.1 
Summary0008474: Crash when trying to get the key of a control bound to a function clientside
Description

The title says all. When I try to get the key bound to a function clientside the game crashes. Here it is the crash information, if it's helpful:

Version = 1.3.5-release-6596.0.000
Time = Tue Aug 19 19:16:39 2014
Module = D:\MTA San Andreas 1.3\mods\deathmatch\client.dll
Code = 0xC0000005
Offset = 0x000FA35F

EAX=00000000 EBX=0D4050E8 ECX=0D0C9F88 EDX=00000000 ESI=192BE310
EDI=194E4590 EBP=0028F558 ESP=0028F51C EIP=13EBA35F FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

I'm using 1.3.5-release-6596.0.000, but I think that this can be reproduced in 1.4 as well.

I think that this issue it's important to fix, because you can't use this to get the key that a player uses for a certain control (and that's neccesary for some scripts like mine, because the "aim_weapon" control doesn't trigger when in a vehicle).

Steps To Reproduce

Create a resource with this code in a clientside script:

function aRandomFunction()
-- No matter what is in here
end
bindKey("aim_weapon", "down", aRandomFunction)

function makeMTACrash()
outputDebugString(getKeyBoundToFunction(aRandomFunction))
end
addCommandHandler("crashme", makeMTACrash)

And type the command /crashme.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change