View Issue Details

IDProjectCategoryView StatusLast Update
0008450Multi Theft Auto : San AndreasClientpublic2018-07-22 21:58
ReporterbuckeyesdbAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.4 
Target VersionFixed in Version 
Summary0008450: Bind Keeps Removing Itself
Description

With the newer gate system on the server I play, you have to do /gate [password] instead of /[password]. When I bind this I use /bind 3 gate [password]. Anytime I restart MTA:SA, it removes the bind, completely. I've tried using the console to set them then /disconnect'ing but it did the same. I went into the coreconfig.xml and manually created the bind but when I go onto the server, it does not work, then I reopen the .xml and the bind line is gone. And I did double check, it is upon connecting to the server I play it removes the bind, not necessarily when I close MTA:SA. I have had this problem before with other command and it was due to the account-system. It was setting 1, 2, and 3 to languages. Not sure if it matters, 3 also has a couple other binds on it such as /duty and /watch [password].

This is the line I use in the .xml:
<bind key="3" state="down" command="gate" arguments="PASSWORD"></bind>
(No, PASSWORD is not actually my password, but for the ease of discussion, we will use it.)

It is just weird because while I'm ingame, and I bind it, it works the rest of the time, until I close MTA:SA. Everytime I get on the server I have to rebind it and the password is somewhat long so I definitely want it bound.

I am not running a nightly update. I ran it as admin like a friend suggested and it saved one of my /gate [password]'s but not the other. When I do it ingame, and check the .xml, it does this: http://puu.sh/aKUW3/ffc23c5c39.PNG

That is on 'U', not '3' but I just haven't attempted to re-assign it yet. It just seems weird it allows one of them to stay, but the second one does not.

Ten minutes later: I just bound Password2 to 3 while Password1 was on U. I disconnected and quit. The binds were in the .xml, I started to connect to the server and while it did that, I reloaded the .xml and it removed Password2, but kept Password1. Weeeiirrddd

Twenty minutes later: SOO... I think I found the problem. I was able to keep one bind on'U' but couldn't put the other one on it aswell, so I put it on 'N'. Both stayed fine and dandy after restart and reconnect. All is good. I went into the Binds Interface and set them both to '3' and disconnected and restarted and reconnected. BOTH were removed. It seems it will not allow me to have two /gate's on the same key, and if there's two, it removes both.

Know a fix for that other than just using separate keys?

Steps To Reproduce

Bind multiple /gates to one key

Additional Information

The description may be confusing because I just copy and pasted how I explained it on the servers Forum Help page

TagsNo tags attached.

Relationships

related to 0009178 resolvedBonus1702 unbindKey not working properly 

Activities

Grafu

2014-08-10 21:54

viewer   ~~0021718

I believe you are not allowed to save more than 2 (not sure about the amount) binds on a single key.

buckeyesdb

2014-08-11 22:53

viewer   ~~0021743

You can have multiple binds to a key I know, but it's not letting me have two /gate's to one key, which makes sense, but i need more than one haha

myonlake

2018-07-22 21:20

updater   ~~0026845

Able to reproduce in Multi Theft Auto v1.5.5-release-13192. Should we be able to save multiple binds on one key with different arguments? I don't see why not.

Issue History

Date Modified Username Field Change